
- / 

I DR 
Draw, 

- ... --.----------.----~----.----
DR Draw™ 
Graphic Application 

User's Guide 



[!ill 
DIGITAL 

RESfARCH® 

DR Draw™ 
Graphic Application 

User's Guide 



COPYRIGHT 

Copyright © 1984 by Digital Research Inc. All rights reserved. No part of this publica
tion may be reproduced, transmitted, transcribed, stored in a retrieval system, or 
translated into any language or computer language, in any form or by any means, 
electronic, mechanical, magnetic, optical, chemical, manual or otherwise, without the 
prior written permission of Digital Research Inc., Post Office Box 579, Pacific Grove, 
California, 93950. 

Preliminary versions of software and documentation for DR Draw were acquired 
through a technology exchange agreement with TeleVideo Systems Incorporated of 
Sunnyvale, California. 

DISCLAIMER 

Digital Research Inc. makes no representations or warranties with respect to the 
contents hereof and specifically disclaims any implied warranties of merchantability 
or fitness for any particular purpose. Further, Digital Research Inc. reserves the right 
to revise this publication and to make changes from time to time in the content hereof 
without obligation of Digital Research Inc. to notify any person of such revision or 
changes. 

NOTICE TO USER 

From time to time changes are made in the filenames and in the files actually included on 
the distribution disk. This manual should not be construed as a representation or 
warranty that such files or materials and facilities exist on the distribution disk or as part 
of the materials and programs distributed. Most distribution disks include a 
"README.DOC" file. This file explains variations from the manual which do consti
tute modification of the manual and the items included therewith. Be sure to read this file 
before using the software. 

TRADEMARKS 

Digital Research and its logo are registered trademarks of Digital Research Inc. 
DR Draw is a trademark of Digital Research Inc. 

The DR Draw Graphic Application User's Guide was printed in the United States of 
America. 

First Edition: 
Second Edition: 

Release: 

January 1984 
March 1984 
1.0 



Foreword 

INTRODUCTION 

STRUCTURE OF 
THIS MANUAL 

This manual teaches you how to produce a wide range of 
presentation-quality graphics with DR Draw TM, including 
organizational charts, flow charts, structured analysis dia
grams, and line illustrations. You can display pictures cre
ated with DR Draw on color and monochrome display 
monitors, or you can use a printer, plotter, or camera to 
present your pictures on paper, transparencies, or print or 
slide film. 

The DR Draw T
" Graphic Application User's Guide con

tains six sections and two appendixes. 

• Section 1 is a brief overview of DR Draw, after which 
you begin the first of two tutorials. 

• Section 2 is a beginning tutorial in which you draw a 
basic organizational chart and a graphic design that 
you might use for a report cover. 

• Section 3 is an advanced tutorial in which you modify 
and embellish the designs you created in the beginning 
tutorial. 

• Section 4 describes several concepts that are fun
damental to DR Draw. 

• Section 5 describes each of DR Draw's functions in 
alphabetical order. 

• Section 6 describes DR Draw's seven design elements, 
also in alphabetical order. 

• Appendix A describes the font library, which lets you 
enter text in several different type styles, including Ro
man, italic, script, Greek, and gothic fonts. 

• Appendix B describes error messages that you might 
see while starting or using DR Draw. 
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CONVENTIONS 

ILLUSTRATIONS 

This manual uses several conventions involving capitaliza
tion and colored type. 

In the text, DR Draw's functions, design elements, and 
layouts are capitalized, although they are not capitalized in 
the menus you see on your display monitor. For example, 
the text refers to the COPY function, the POLYGON de
sign element, and the PORTRAIT layout. Functions, in
cluding LAYOUT, are described in Section 5; design ele
ments are described in Section 6. 

To help you identify filenames and filetypes (like 
CHART.PIX), they are capitalized in the text and in exam
ples of prompts and messages. However, you need not 
capitalize filenames when you use DR Draw. 

The names of three keystrokes, PICK, DONE, and RE
TURN, are also capitalized in the text. 

DR Draw's menus and submenus appear with initial capi
talization. You will see references to the Main Menu, Edit 
Menu, and Change Submenu, among others. 

Examples of DR Draw's prompts and messages appear in 
Dot Matrix colored type. User input appears in Oblique 
colored type. 

The figures in this user's guide were produced with DR 
Draw. 
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RELATED 
PUBLICATIONS 

Before you start to use DR Draw, be sure you read the DR 
Draw User's Guide Supplement (cited as Supplement in 
this manual) you received with DR Draw. The Supplement 
describes how to copy your DR Draw diskettes, format a 
picture file diskette, and start DR Draw. It also provides 
information about the devices you can use with DR Draw. 

In addition, you should be familiar with your hardware 
and software. For information on the particulars of your 
system, refer to the documentation that came with your 
computer, display monitor, printer, plotter, camera, and 
mouse. 
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Section 1 

OVERVIEW 

INTRODUCTION 

YOUR COMPUTER 

DR Draw allows you to use your microcomputer to com
municate your ideas with high-quality graphics. DR 
Draw's capabilities give form to your imagination, allow
ing you to create your own graphic designs. With DR 
Draw you can create, preview, change, and refine a draw
ing before you print or plot it. 

This section introduces you to DR Draw, explains its fea
tures and capabilities, and previews the sections that fol
low. 

Your computer and its output devices (display monitor, 
plotter, and printer) use DR Draw to help you create effec
tive presentations. The computer frees you from the repeti
tive tasks of aligning, changing, and repeating figures. 
Your monitor is a window into a two-dimensional drawing 
surface where you can create drawings that bring your 
ideas to life. 

The pictures you create may be charts, diagrams, or free
form graphics. The pictures are easily reproduced on paper 
or transparencies for presentation. Your design and the 
capabilities of DR Draw combine to produce pleasing and 
imaginative pictures like the one shown in Figure 1-1. 

I!ID DIGITAL RESEARCH® ---------------------------
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Your Computer 

CAPABILITIES 

DR Draw User's Guide 

Figure 1-1. Picture Created with DR Draw 

With DR Draw you can do the following: 

• add a variety of design elements that include 

-circles 
-polygons 
-bars 
-lines 
-arcs 
-text 

• combine design elements to create pictures 

• change size and dimensions of design elements 

• use a palette of colors to enhance pictures 

• use a library of typefaces 

• create word-slides with text alone 

--------------------------- I!IDDIGITAL RESEARCH® 
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DR Draw User's Guide Capabilities 

USING THIS 
MANUAL 

• edit your picture 

• save pictures on diskette 

• get a presentation-quality copy of your work from a 
printer, plotter, or camera 

• enlarge part of a picture 

• expand a design beyond the confines of the display 
monitor 

Two tutorials in this manual help you build a foundation 
for success with DR Draw. 

The tutorials acquaint you with the basics of DR Draw and 
allow you to progress rapidly. Section 2 contains the first 
tutorial and provides step-by-step practice in basic DR 
Draw functions. You learn by creating charts and designs 
on the drawing surface. In this beginning tutorial, you also 
learn how to save your picture files on diskette. 

Section 3 presents the advanced tutorial, which builds 
upon skills acquired in the beginning tutorial. It introduces 
to you more powerful features of DR Draw that let you 
create more complex designs. 

Section 4 provides detailed descriptions of concepts the 
tutorials introduce. Section 5 provides descriptions of all 
DR Draw functions and Section 6 explains the DR Draw 
design elements. 

Appendix A describes DR Draw's font library. Appendix B 
lists and explains error messages that can occur when you 
start or use DR Draw. 

Use this manual with the Supplement, which tells you how 
to install and start DR Draw on your computer system. 

[!Q] DIGITAL RESEARCH® ---------------------------

1-3 



Using Keyboard or Mouse 

USING KEYBOARD 
OR MOUSE 

DR Draw User's Guide 

DR Draw can be used with a variety of computers. You 
can use either a mouse or keyboard to communicate with 
DR Draw. 

You use two special keystrokes or mouse buttons to per
form two important DR Draw functions: PICK and 
DONE. PICK allows you to select a menu item or location 
on the drawing surface. . 

DONE completes an operation. In some cases, PICK per
forms and ends an operation without requiring DONE. 

Table 1-1 shows the keys or buttons used for PICK and 
DONE: 

Table 1-1. PICK and DONE (Keyboard/Mice) 

PICK 

DONE 

DR Draw MENUS 

Keyboard 

SPACE BAR 

RETURN 

2-Button 
Mouse 

e=J 
[J 

3-Button 
Mouse 

CJ 
CJ 

DR Draw is a menu-driven program. You choose functions 
from a series of menus. The Main Menu provides a list of 
major DR Draw functions; several lead to submenus that 
contain more functions. 

-------------------------- I!IDDIGITAL RE.SEARCH® 
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DR Draw User's Guide Menu Map 

MENU MAP The menu map below routes you through the menus of
fered by DR Draw. 

operating 
system 

Main Menu 

'----------Edit Menu 

submenu submenu 

Figure 1-2. Menu Map 

End of Section 1 
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Section 2 

GETTING STARTED 

INTRODUCTION 

START DR Draw 

With DR Draw you can easily create many kinds of charts, 
diagrams, and other graphic designs. This section helps 
you teach yourself to use DR Draw. 

By following the steps in this tutorial, you quickly become 
familiar with DR Draw's capabilities and learn to create 
your own pictures. 

In this tutorial you create two sample drawings: an organi
zational chart, and a design suitable for a report cover. 

You must set up your computer and start DR Draw before 
you begin the tutorial. 

Your method of starting DR Draw depends on the type of 
computer system you use. Refer to the Supplement for in
formation on starting DR Draw. 

You need two diskettes to operate DR Draw: the work 
diskette that contains DR Draw and a formatted diskette 
on which to store your picture files. Refer to the Supple
ment for information on formatting diskettes. 

I!ID DIGITAL RE.SEARCH@ ---------------------------
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Create a Chart 

CREATE A CHART 

TINA GANZ 
CONSULTANT 

MAIN MENU 

DR Draw User's Guide 

An organizational chart communicates the hierarchy of a 
business. In the first part of this tutorial, you learn how to 
create the first few boxes in the organizational chart shown 
in Figure 2-1. 

TUNNEY ElECTRONICS CORPORATION 

HUME CLAYBURN 
ADVERTISING 

Figure 2-1. Organizational Chart 

TYRONE SMITH 
MANUFACTURING 

This tutorial teaches you how to do the following: 

• create a picture file 
• use the grid 
• add design elements, including text 
• copy design elements 
• move a design element to another location 
• save and recall your picture file 
• print output from the picture file 

When you start DR Draw, a copyright ~essage appears on 
the screen. The message is soon followed by the Main 
Menu, a bar at the top of the screen that lists the main 
functions of DR Draw. 

--------------------------- I!ID DIGITAL RESEARCH® 
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DR Draw User's Guide 

_ Reca\\ 

MOVING THROUGH 
THE MENU 

Main Menu 

Edit Save I Directory I Output 

Figure 2-2. Main Menu 

If you are using a mouse, you can move through the menu 
by moving the mouse left or right. For systems without a 
mouse, use the TAB key to move through the menu, left to 
right. The BACKSPACE key reverses movement through 
the menu, right to left. On keyboard systems and some 
mouse systems, the menu selection appears in reverse 
video. 

Practice moving through the menu bar a few times. 

I!ID DIGITAL RESEARCH® --------------------------
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PICK 

PICK 

CREATE A 
PI CTURE FILE 

DR Draw User's Guide 

Now begin a picture by using PICK to select a menu item. 
If you are using a mouse, press the button on the far left to 
PICK. On the keyboard, press the SPACE BAR to PICK. 
To avoid confusion, the action is referred to simply as 
PICK throughout this guide. 

From the Main Menu, PICK the CREATE function to cre
ate a picture file. 

When you PICK the CREATE function, DR Draw prompts 
you to name the picture file: 

Picture filenaMe? 

When you type a filename, you must tell DR Draw which 
drive contains your picture diskette. DR Draw stores the 
picture file on that diskette. For example, if your picture 
diskette is in drive B, you type the drive identifier 

f3: 

before the filename. 

In response to the picture filename prompt, type the correct 
drive identifier and the filename: 

f3:CHI1RT 

If you misspell the filename, use the BACKSPACE key to 
erase the mistake, and retype the name. Press the RETURN 
key. 

For the filename you can use any combination of letters or 
numbers that does not exceed eight characters. DR Draw 
ignores characters after the eighth character. Also, do not 
use punctuation marks or spaces. 
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DR Draw User's Guide 

_ Change 

Create a Picture File 

The Main Menu disappears and a rectangle appears, rapid
ly filling with a grid of points. The rectangle is the window 
frame. It encloses the drawing surface where you work. A 
new menu bar replaces the Main Menu. This is called the 
Edit Menu, and it lists the functions you can use to make 
your organizational chart. The grid of points acts like elec
tronic graph paper to help you align different design ele
ments. 

Select Move COPY I Un de tete I De tete 

Figure 2-3. Edit Menu, Grid, and Window Frame 
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Draw Elements DR Draw User's Guide 

DRAW ELEMENTS To draw the organizational chart, you add different design 
elements to the grid one by one, much in the way a graphic 
artist builds a design with overlays. A design element is any 
shape, symbol, or unit of text that you use in the picture. 
You begin by using lines to draw boxes. 

RETURN AND DONE If you PICK the wrong menu item here or anywhere in the 
tutorial, press the DONE key to return to the previous 
menu, and PICK again. On keyboard systems, you press 
the RETURN key for DONE. On a mouse, the second 
button from the left signals DONE. 

DRAW LINES 

If you press the DONE key when you are in the Edit Menu, 
your picture disappears from the screen, and the Main 
Menu appears. To return to the Edit Menu and continue 
working on your picture, PICK the EDIT function from the 
Main Menu. 

PICK the ADD function from the Edit Menu. A new menu 
of shapes and figures appears below the Edit Menu. These 
are the design elements you use to create your picture. 
Refer to Section 6 for descriptions of DR Draw's design 
elements. 
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Figure 2-4. Edit Menu and Add Submenu 

PICK the LINES design element from the Add Submenu. A 
cross hair (+), called the graphics cursor, appears at the 
center of the drawing surface. The center of the cursor 
marks your position on the drawing surface. The graphics 
cursor appears when you PICK a menu item that adds a 
design element or changes a picture element. The cursor 
also appears when you need to PICK a point for reposition
ing elements or changing your view of the drawing surface. 
For details on the graphics cursor, refer to Section 4. 
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On the second menu line, DR Draw tells you 

PICK pointst press DONE when finished 

You begin creating the organizational chart by drawing 
lines. You PICK starting and ending points. DR Draw joins 
the two points to form a line. You can add additional line 
segments by adding successive points to the element. 

If you are using a mouse, move it, and the graphics cursor 
moves correspondingly. On a keyboard system, use the 
arrow keys to move the cursor. If you are using arrow keys, 
note that each press of an arrow key moves the cursor part 
of the distance between grid points. For example, you 
might press the cursor key five times to move 4 grid points 
across the drawing surface. 

To begin drawing the chart, locate your cursor at the cen
ter grid point on the drawing surface. Move the cursor 
straight up 3 grid points and PICK. This is your starting 
point. No line appears, but you might have noticed that the 
cursor attaches to the nearest grid point if you were not 
directly over a grid point. This is the SNAP feature, which 
helps you align design elements by "snapping" the cursor 
to the nearest grid point on the drawing surface. The SNAP 
feature is useful for aligning design elements in a picture. 

Move the cursor left 4 grid points. On most systems, a line 
follows the cursor. This is DR Draw's rubberband line, 
which allows you to see how the line looks before you 
PICK an endpoint. 

PICK the point. The dashed line becomes a solid line be
tween the two points you PICKed-the beginning of a box. 
See Figure 2-5, "First Line Segment." 
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MOlJe Undelete De I,ete 

Figure 2-5. First Line Segment 

Now move the cursor up 3 grid points on the grid and 
PICK again. Another solid line appears. 

You can move the cursor over the drawing surface freely. 
Line segments join only the points that you PICK. 
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'. ~ . 

DR Draw User's Guide 

Move the cursor 8 grid points to the right and PICK once 
more. Another line appears. Your box is more than half 
complete. 

Move the cursor 3 grid points down and PICK. One more 
line segment completes the box. Move the cursor 4 grid 
points to the left to the point where you began and PICK. 
The final line closes the box. Now press the DONE key to 
tell DR Draw that the element is complete. You have cre
ated your first design element with DR Draw. 

Undelete r De tete 

, . 't----- ~- ..;~-~ 

I" ,.," ",', ""'" 1 
" l'" I.' _ I, I _ ~ J - , _. _ I 

,. ___ -u-, __ -" 
."; ',,- - -''-, 

Figure 2-6. First Box 

The Add Submenu and the graphics cursor disappear. A 
broken line, enclosing the box you just drew, appears on 
the drawing surface. 
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DELETE AND 
UNDELETE 

Draw Lines 

The broken line is the extent. It marks the current element. 
The current element is the only design element you can 
change. Ordinarily the current element is the most recent 
design element you worked on. However, when you save a 
picture file on diskette and recall the file, the first element 
you added to the picture becomes the current element. 

The advanced tutorial in Section 3 explains how to use the 
SELECT function to name a new current element. 

If you made a mistake and want to redraw the box, you 
can delete the design element with DR Draw's DELETE 
function. DELETE removes the current element from the 
drawing surface. 

If you accidentally delete an element, the UNDELETE 
function redraws the last element you deleted, regardless of 
the number of operations you performed since the deletion. 

Practice DELETE and UNDELETE. PICK the DELETE 
function from the Edit Menu. DR Draw erases the box. 

Notice that the grid points below the deleted box also 
disappear. You can restore the grid points by using the 
REDRAW function. PICK the CHANGE function from 
the Edit Menu. From the Change Submenu, PICK the 
REDRAW function. DR Draw erases the grid, then re
draws the grid to restore the missing grid points. 

PICK the UNDELETE function. DR Draw redraws the box 
you deleted on the drawing surface. The extent reappears, 
defining the box as the current element. 
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COPY ELEMENTS 

DR Draw User's Guide 

To proceed with the organizational chart, you want to 
draw several more rectangles. You do not have to redraw 
each box with the LINES design element. Instead, use 
another DR Draw function, COPY. 

PICK the COpy function from the Edit Menu. The 
graphics cursor reappears. DR Draw prompts 

PICK reference point 

Move the cursor to the upper left corner of the current ele
ment. By positioning the cursor on or near the extent corner, 
you can more easily locate new elements. PICK the point. 

_. Undel.ete ·1 · Delete 

' .. J';' " , , , , 

, : 1.\ .... ·.--.' ...... -..-.'.'--. -. Uj 
, , ·1 ..... ".' , ". '.' . 
, ,;;' ... II 

?'t~" ~ - - - - - - - - ~ 

...... ----_ ...... -_ ............ __ .......... ---........ -.. .... ----............ - ........ --

Figure 2-7. Cursor Position (COpy) 
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A new prompt appears. 

PICK locatiords), press DONE to finish 

Move the cursor 7 grid points down, then 10 grid points 
left. PICK again. A duplicate of your first box appears 
below and to the left of the original. The extent now sur
rounds the new box, which is the current element. The 
prompt remains on the screen. . 

_ Onde I,ete I De tete 

1-.:...:-..:.:....:-!-~ 
, ""'" I 
'I, ' , , , , , , I 
, :C .. - - - - - - - - - - ! 

Figure 2-8. Second Box 

COpy allows you to make as many copies as you wish in 
the same operation, as long as the total number of elements 
in the picture does not exceed 200. 
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MOVE ELEMENTS 

DR Draw User's Guide 

Now add another box to the chart. Using the upper left 
corner of the new box as the starting point, move the 
cursor 21 grid points to the right and PICK once more. 
Another copy of the box appears, surrounded by the ex
tent. 

Press the DONE key to finish copying. DR Draw returns 
you to the Edit Menu. 

The last box you added to the picture is slightly off center. 
DR Draw's MOVE function makes it easy to realign your 
chart. 

The MOVE function allows you to move the current ele
ment anywhere on the drawing surface. 

PICK the MOVE function from the Edit Menu. DR Draw 
prompts 

PICK reference point 

Move the cursor to the upper left corner of the extent. 
PICK the point. A prompt appears. 

PICK new locationt press DONE to finish 

Move the cursor 1 grid point to the left and PICK. The box 
shifts to the new position. You are still in the MOVE func
tion, so you could move the box again if necessary. Press 
the DONE key to return to the Edit Menu. 
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CHANGE GRID SIZE 

Move Elements 

Select Move COPY Undelete I De\ete 

11 - - - - - - - - - --~ 

~ " " I 
~ - ~ ~ ~ - '- ~ ~ -'--~ 

Figure 2-9. Third Box 

Before you add text to the boxes you should substitute a 
denser grid for the present grid. Adding more grid points to 
the drawing surface lets you more easily position text with
in the boxes. The GRID function allows you to change grid 
density. 

From the Edit Menu, PICK the CHANGE function. The 
Change Submenu appears under the Edit Menu. PICK the 
GRID function. The Grid Submenu replaces the Change 
Submenu. PICK the SIZE O.SX function. The grid dis
appears, line by line, and a new, denser grid appears on the 
drawing surface. The new grid is twice as dense as the 
original grid. The Grid Submenu disappears. 
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ADD TEXT 

DR Draw User's Guide 

The trio of boxes is a start, but you need to add labels to 
them. Like shapes, you add text with the ADD function. 

PICK the ADD function from the Edit Menu. When the 
Add Submenu appears, PICK the TEXT design element. 
DR Draw prompts 

PICK startt typet RETURN; DONE finishes 

If you are using the arrow keys to move the cursor, you can 
more easily locate grid points by slowing the cursor. A 
designated key on your keyboard changes the cursor's 
speed. Refer to the Supplement to identify the key. 

You change the cursor speed by pressing the key to in
crease or decrease speed. When you identify the cursor 
speed key, practice moving the cursor around the drawing 
surface and alternating between fast and slow speed. 

When you feel comfortable with changing cursor speed, 
you can add text to the first box you created by completing 
the following instructions. 

Within the top box, move the cursor 3 grid points up from 
the box's lower left corner, then move the cursor 4 grid 
points to the right. PICK the point. The graphics cursor 
disappears. An underscore, the text cursor, replaces the 
graphics cursor. 
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COPy Undelete I Delete 
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Figure 2-10. Text Cursor 
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Type the following: 

DAVE MITRE 

If you make a typing error, use the BACKSPACE key and 
retype the box label. 

After you type the text string, press the RETURN key. The 
graphics cursor appears below the letter D. 

Press the DONE key to finish entering text. The extent 
appears around the text you just typed. 

For detailed information on entering text, refer to 
Section 6. 
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I ~ , • I j , • I I ,I I 0" t I,," I , I I .' • I, I I If" I' { .. " I I" , • I • .' 1 • I • " " t • , • j' , I I I', , I , • , I 

:.: : : : : : : : : : :.: : :. : : : : : : : ·r:-,-1:-;~-";~~1-:-:-~ : : : :.: : : : : : : : : : : : : : : : : : 
" , , , , , , , , , , , , , , . , , , , , I ' , 'IDAVE M ITRq . , , I ' , , , , , " , , , , , , , , , , , , , , 

:~ ~;; ; ~:: ; ; :; ; : : : : : :. : : L~~~~~=:~=~~~~~J ;: ;; : ~ ; :: : : :: ;;: : :: ;; : 

I.' 1'1 t " t 'I' • It, t • I I I • I. , , • I' " " • I, " 11 I I I 1"'1'1 I I., I " I • 

• •• 1'1 I I I 1'1' •• , 'I' ,. " ,. , • I. I I " .' • I I I I. I I I I I, 0" I " I I I' , ,. " • 

Figure 2-11. Box Label 
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CHANGE TEXT 
STYLE 

ADD MORE TEXT 

Change Text Style 

The style of text DR Draw used for your text entry is 
known as machine font. This is the initial style that DR 
Draw uses for all text until you specify otherwise. The size 
and shape of machine font characters may vary between 
different computers and output devices, so you want to 
change the font style to one of the typefaces included with 
DR Draw. These fonts remain the same on screen, plotter, 
and printer outputs. 

PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the STYLE function. 
A submenu of font options appears. PICK the Simplex 
submenu selection. The font Simplex Roman replaces the 
initial style in the box label. 

Now add a title to the name you entered in the first box. 
PICK the ADD function from the Edit Menu. From the 
Add Submenu, PICK the TEXT design element. DR Draw 
prompts 

PICK start, type, RETURN; DONE finishes 

Use the lower left corner of the first box as a starting point. 
Move the cursor up 1 grid point and 5 grid points to the 
right of the box's lower left corner. 
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Figure 2-12. Cursor Position (TEXT) 

PICK this point. The text cursor replaces the graphics cur
sor. Type the following: 

DIRECTOR 

The words appear in the machine font as you type. A 
bouncing extent surrounds the text to show you the size of 
the element as it will appear in the current font style, Sim
plex Roman. Press the RETURN key. The font style 
changes to Simplex Roman, and the cursor moves to the 
next line. 
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When you press the RETURN key after typing a string of 
text, you can use the mouse or arrow keys to move any
where on the drawing surface, PICK a point, and type 
another text string. This feature enables you to add the 
remaining box labels in one operation. 

Using the labels in Figure 2-13, add text to the remaining 
boxes. Type the names on the third row of grid points 
above the boxes' lower edges. Type the titles on the first 
grid row above the lower edges. Do not worry if the text is 
not centered perfectly the first time you add the labels. 
Press the DONE key when you are finished. 
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Figure 2-13. Labeled Boxes 
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CHANGE GRID 

ADD LINES 

DR Draw User's Guide 

Before you join the labeled boxes with lines, change the 
grid density. A sparser grid of dots lets you more easily 
count grid points for centering lines. 

From the Edit Menu, PICK the CHANGE function. When 
the Change Submenu appears, PICK the GRID function. 
The Grid Submenu replaces the Change Submenu. PICK 
the SIZE 2X function. The grid disappears, line by line, 
and a new, less dense grid appears on the drawing surface. 
The new grid is half as dense as the previous grid. 

To complete the chart, you need to join the rectangles with 
lines. 

PICK the ADD function from the Edit Menu. When the 
Add Submenu appears, PICK the LINES design element. 

DRDraw tells you 

PICK pointst press DONE when finished 

Use PICK to draw line segments between the boxes. Start
ing from the lower right corner of the top box, move the 
cursor 4 grid points to the left. Because the cursor snaps to 
the nearest grid point when you PICK, move the cursor 
close to the center grid point on the box's lower edge. See 
Figure 2-14. PICK the point. The cursor snaps to the 
nearest grid point. 

-------------------------- I!ID DIGITAL RESEARCH® 

2-22 



DR Draw User's Guide 

_ Change I Se teet Move COPY 
PI\~K pomts, press DONE when flnlshed 

,------, 
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Add Lines 

Undelete I Delete 

Figure 2-14. Cursor Position (Adding Lines) 
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Move the cursor down 2 grid points and PICK. A line 
appears between the two points. Now you want to create 
two line segments that branch out to the remaining boxes. 
Move the cursor 10 grid points to the right. PICK the 
point. 

Now move the cursor down 2 grid points and PICK. A line 
joins the two boxes. See Figure 2-15. 

I--~-'---~--I· 
I ' NANC:rT~NGI 

1~_~RK£:rIN'::_~ 

Figure 2-15. Boxes Joined with Line 
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SAVE A PICTURE 

Add Lines 

You now want to join the box on the left to the rest of the 
diagram. You can do this by pressing the DONE key and 
PICKing the LINES design element again from the Add 
Submenu, or you can retrace your steps by completing the 
following instructions. 

Move the cursor back up 2 grid points and PICK again. 

Your figure looks the same because you have drawn a line 
on top of another line. Move the cursor 20 grid points to 
the left. PICK the point. 

As you move the cursor, the right side of your line may 
disappear. The rubberband line following the cursor cre
ates this effect. Your line is still there. 

To draw the final line, move the cursor down 2 grid points 
and PICK. 

Press the DONE key to complete the line element. Notice 
that the extent traces a rectangle around the entire line 
element. 

You have drawn a simple organizational chart with DR 
Draw. The advanced tutorial in Section 3 teaches you how 
to expand this chart into the organizational chart shown in 
Figure 2-1. 

Now that your chart is complete, you can save it on disk
ette for future reference. 

Press the DONE key. The organizational chart, window 
frame, and grid disappear. The Main Menu replaces the 
Edit Menu at the top of your screen. 

PICK the SAVE function. DR Draw prompts 

B:CHART? (or type new naMe) 
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CHECK DIRECTORY 

RECALL PICTURE 
FILE 

DR Draw User's Guide 

DR Draw is gIvmg you the opportunity to change the 
filename. Changing a filename is discussed in "Rename 
Picture File" later in this tutorial. You can also change the 
drive identifier if you want to store the picture file in a 
different drive. Refer to "Create A Picture File" at the 
beginning of this section for an explanation of drive iden
tifiers. 

To keep the same picture filename and drive identifier, 
press the RETURN key. DR Draw replies 

B:CHART: savin~ file 

N ow check your directory of picture files to ensure 
CHART has been saved on the diskette. 

To list the picture files on diskette, PICK the DIRECTORY 
function from the Main Menu. DR Draw prompts 

On IAlhich drive? 

Type the letter of the drive that contains your picture 
diskette and press the RETURN key. DR Draw lists the 
picture files on the diskette. Check to see if the picture file 
CHART is listed. DR Draw returns you to the Main Menu. 
The directory remains on the screen until you PICK another 
function and it uses the drawing surface. 

To retrieve your picture file to display or modify it, use the 
RECALL function. In this case you will be preparing the 
picture file for printing. 

PICK the RECALL function from the Main Menu. DR 
Draw prompts 

B:CHART? (or type new name) 

Press the RETURN key. DR Draw prompts 

B:CHART: readin~ file 
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LAYOUT 

_ Change 

Recall Picture File 

DR Draw draws your chart on the screen and displays the 
Edit Menu. The first element created, a box, is now the 
current element. 

Before you print the picture file, use the LAYOUT function 
to format your picture file. DR Draw only prints the por
tion of a picture file that lies within the layout. Elements 
outside the layout are not printed even though they are 
part of the picture file. 

DR Draw gives you a choice of three layouts: PORTRAIT, 
LANDSCAPE, and SCREEN. The examples in Figures 
2-16a through 2-16c illustrate the three different layouts. 

Se led Move COPY I undetete I Delete 

..... -------..... -------------...... --~ ...... ----...... --

Figure 2-16a. LANDSCAPE Layout 
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Figul'e 2-16b. SCREEN Layout 
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_ Change Select Move COPY Undelete I Delete 

• t ••• 

Figure 2-16c. PORTRAIT Layout 

SCREEN is the default layout, the format that DR Draw 
uses if you do not select a layout. 

Now look at how LAYOUT can affect the picture file. 
PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the LAYOUT func
tion. The Layout Submenu appears. PICK the PORTRAIT 
layout. DR Draw adds a solid-line rectangle to the grid. 
You can see that part of the chart lies outside the POR
TRAIT layout. 
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Now try the LANDSCAPE layout. PICK the CHANGE 
function from the Edit Menu. When the Change Submenu 
appears, PICK the LAYOUT function. PICK the LAND
SCAPE layout from the Layout Submenu. DR Draw re
places the PORTRAIT layout with the LANDSCAPE lay
out. Note that in this case LANDSCAPE, like PORTRAIT, 
does not frame all the elements in the organizational chart. 

Refer to Section 5 for more details on the LAYOUT func
tion. 

You can fit the organizational chart into the LANDSCAPE 
layout by using DR Draw's ZOOM FULL function. 
ZOOM FULL reduces or enlarges the picture file to fit the 
current layout. 

From the Edit Menu, PICK the CHANGE function. When 
the Change Submenu appears, PICK the VIEW function. 
The View Submenu appears on the screen. PICK the 
ZOOM FULL function. DR Draw proportionally reduces 
the contents of the picture file to fit the LANDSCAPE lay
out. 
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Figure 2-17. Organizational Chart in LANDSCAPE Layout 

RENAME PICTURE 
FILE 

You can only print a picture file when it is saved on disk
ette. Press the DONE key to return to the Main Menu. 
PICK the SAVE function from the Main Menu. DR Draw 
prompts 

B:CHART? (or type new naMe) 
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PRINT PICTURE 
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Because you need to keep the original CHART for the 
advanced tutorial in Section 3, you must rename this ver
sion of the picture file. To rename the picture file, type 

B:CHART2 

in response to the prompt, and press the RETURN key. DR 
Draw displays this message: 

5:CHART2: sauin~ file 

When the message disappears, DR Draw has saved the new 
picture file on diskette. 

You now have two versions of the organizational chart on 
your picture diskette. CHART is your original version in 
SCREEN layout. CHAR T2 contains the same design ele
ments, but the file is in LANDSCAPE layout. 

If you had pressed the RETURN key without typing a new 
filename, DR Draw would have replaced the version of 
CHART saved on your diskette with the version on which 
you have been working. 

Use the OUTPUT function to print the picture file 
CHART2. 

PICK the OUTPUT function from the Main Menu. DR 
Draw displays a new menu that offers a choice of output 
devices. 
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Figure 2-18. Output Submenu 

PICK PRINTER from the Output Submenu. The Output 
Submenu disappears and DR Draw prompts 

B: CHART2? (0 r t }'pe nel ... 1 nafr\e) 

Press the RETURN key. 

After a pause, the picture file begins to print. When print
ing is complete, the Main Menu reappears. 

Congratulations, you have completed the first sample 
drawing in this tutorial and learned some basic DR Draw 
functions in the process. The sample picture that follows 
introduces you to more DR Draw functions. 

liID DIGITAL RESEARCH® -:--------------------------

2-33 



Print Picture 

CREATE A DESIGN 
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If you want to take a break from the tutorial, PICK the 
EXIT function from the Main Menu to return to the oper
ating system. The operating system prompt appears, which 
signals your departure from DR Draw. To restart DR 
Draw, follow the instructions in the Supplement. 

In addition to creating charts and other diagrams, DR 
Draw allows you to create designs or pictures. In this part 
of the beginning tutorial, you use DR Draw to create a 
pencil design. 

Figure 2-19. Pencil Design 

If you took a break from the tutorial and exited DR Draw, 
restart DR Draw. If you do not remember how to do this, 
refer to the Supplement. 
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CREATE A 
PI CTURE FILE 

Create a Picture File 

To begin, create a picture file in the same way you created 
CHART. 

From the Main Menu, PICK the CREATE function. DR 
Draw prompts you for a filename: 

Picture filenaMe? 

Type the following, then press the RETURN key: 

B:PENCIL 

The rectangular window frame returns to the drawing sur
face. The Edit Menu replaces the Main Menu. You are 
ready to draw. 
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DRAW CIRCLE 
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Start by drawing a circle. PICK the ADD function from the 
Edit Menu. The Add Submenu appears below the Edit 
Menu. PICK the CIRCLE design element. The graphics 
cursor ( + ) appears at the center of the drawing surface and 
DR Draw prompts 

PICK circle center 

Position the cursor on the center grid point on the drawing 
surface and PICK. An asterisk marks the point. DR Draw 
now prompts 

PICK circle radius 

You are ready to tell DR Draw how large the circle will be. 
Move the cursor 6 grid points to the left and PICK. 
Another asterisk marks the point. 

The graphics cursor disappears and a new submenu offers 
you the choice of creating an OPEN circle or a FILLED 
circle. An OPEN circle is a circular line. A FILLED circle is 
a circular line with one of several fill patterns inside. 

PICK the OPEN circle. After a pause, the circle appears on 
the drawing surface, surrounded by the extent. 
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Figure 2-20. Circle and Extent 

Draw Circle 

undelete I Delete 
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ADD POLYGON 
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Now add another element to the design. The POLYGON 
design element allows you to create a filled element with as 
many sides as you want. In this picture, you will be draw
ing a triangle. 

From the Edit Menu, PICK the ADD function again. When 
the Add Submenu reappears, PICK the POLYGON design 
element. 

The graphics cursor appears and DR Draw prompts 

PICK pointst press DONE when finished 

Starting from the center point of the circle you just created, 
move the cursor 14 grid points to the left and PICK. You 
have now marked a corner of the triangle. Now move the 
cursor up 1 grid point and 3 grid points to the right. PICK 
the second point. The first side of the triangle appears on 
the screen. 

To draw the second side of the triangle, move the cursor 
down 2 grid points and PICK. 

To rejoin the starting point, move the cursor 3 grid points 
to the left and 1 grid point up. PICK the point. Press the 
DONE key. 

The cursor disappears, and the triangle turns solid. This 
solid fill is known as the initial style. If you do not specify 
another fill pattern, DR Draw assumes you want the solid 
fill. Notice that your screen shows the solid area in light 
shading. When you print or plot the picture, this area is 
black or solid colored. You will learn how to add or 
change colors in the "Color" subsection of this tutorial. 
For more information on the STYLE function, refer to 
Section 5. 
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Figure 2-21. First Polygon 

[!ill DIGITAL RESEARCH® -----------------------

2-39 



Add Another Polygon 

ADD ANOTHER 
POLYGON 

STYLE 
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Now, use the POLYGON design element to add another 
element to the picture. 

PICK the ADD function from the Edit Menu. When the 
Add Submenu appears, PICK the POLYGON design ele
ment. 

The cursor reappears and DR Draw prompts 

PICK pointst press DONE when finished 

To locate a starting point, move the cursor to the upper 
right corner of the triangle you just created. PICK the 
point. 

Move the cursor up 1 grid point and 3 grid points to the 
right. PICK the point to draw the first side of the polygon. 

Move the cursor down 4 grid points and PICK again. 

Draw the third side of the design element by moving the 
cursor 3 grid points to the left and up 1 grid point. PICK 
the point. 

Complete the polygon by moving the cursor up 2 grid 
points. PICK the point. Press the DONE key. The solid fill 
appears in the polygon. The cursor disappears, and the 
extent encloses the polygon. 

To change the fill pattern of the polygon, use the STYLE 
function. 

PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the STYLE function. 
A menu of different fill patterns appears. 

PICK the first fill pattern. The solid fill disappears, leaving 
the outline of the polygon. The new fill is the hollow fill. 
Although the element looks empty, the hollow fill masks 
any element underneath it. Refer to Section 4 for details on 
hollow fill. 
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Figure 2-22. Second Polygon 

STYLE 

Undetete 1 Detete 
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BARS 
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Now use the BAR design element to draw the body of the 
pencil. With the BAR design element, you can draw rec
tangles in all sizes, ranging from long, thin bars to squares. 
From the Edit Menu, PICK the ADD function. From the 
Add Submenu, PICK the BAR design element. DR Draw 
prompts 

PICK corner of bar 

You define the bar by choosing corners that are diagonally 
opposite each other. 

Move the cursor to the lower right corner of the hollow
filled polygon and PICK. An asterisk marks the point. DR 
Draw prompts 

PICK opposite corner of bar 

Move the cursor up 4 grid points, then 16 grid points to the 
right. PICK the point. A hollow bar appears, and the extent 
encloses the new element. 

Now change the new element's fill to a solid fill. PICK the 
CHANGE function from the Edit Menu. When the Change 
Submenu appears, PICK the STYLE function. From the 
menu of fill patterns, PICK the second style. The solid fill 
replaces the hollow fill in the bar. 
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Figure 2-23. Bar 

You have now created three different elements and.are well 
on your way to completing the picture. 
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COLOR (OPTIONAL) 
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The DR Draw COLOR function allows you to add color to 
your design elements. If your computer or output devices 
have color capabilities, you will want to experiment with 
the COLOR function. Skip this section if neither your com
puter nor output devices have color capability. 

To see the Color Submenu, PICK the CHANGE function 
from the Edit Menu. From the Change Submenu, PICK the 
COLOR function. 

The Color Submenu contains eight rectangles numbered 0 
through 7. On some color monitors the rectangles also 
contain the color represented by the number. 

Printers and plotters do not necessarily have as many col
ors or the same colors as the monitor. For example, your 
monitor might have four colors, and your printer might 
only have three. In addition, color number 2 on your moni
tor might be blue, but on your printer it might be magenta. 

To learn which colors you have on your monitor and prin
ter or plotter, you can make a sample color file, as de
scribed in the description of the COLOR function in 
Section 5. 

If you are working with a monochrome monitor, design 
elements remain monochrome on the display screen, but 
you can still print or plot in color. 

--------------------------- I!IDDIGITAL RESEARCH® 

2-44 



DR Draw User's Guide 

CHANGING COLOR 

COLOR (Optional) 

Figure 2-24. Color Submenu 

To change the color of the BAR design element, PICK color 
number 3 from the submenu. The Color Submenu dis
appears. If you are working in color on the screen, the bar 
changes its color to the hue corresponding to number 3 in 
the menu. 
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ARCS 
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Use the ARC design element to finish creating the pencil. 
An arc is either part of the circumference of a circle, or it is 
a filled pie section. For more information on arcs, see the 
description of the ARC design element in Section 6. 

T a add an arc to the design, PICK the ADD function from 
the Edit Menu, then PICK the ARC design element from 
the Add Submenu. DR Draw prompts 

PICK arc cente r 

Move the cursor down 2 grid points from the upper right 
corner of the bar, then 1 grid point to the right. 

PICK the point. An asterisk marks the arc center. DR Draw 
prompts 

PICK arc radius/beg'inning' of arc 

Move the cursor down 2 grid points and PICK. Another 
asterisk appears and DR Draw prompts 

PICK end of arc 

Move the cursor up 4 grid points and PICK the point. 
Before the arc appears, DR Draw asks you if you want the 
arc OPEN or FILLED. PICK a FILLED arc. After a pause, 
the arc appears. The arc completes the pencil figure. You 
have created a drawing that demonstrates some of DR 
Draw's many functions. 
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SAVE THE PICTURE 

Arcs 

Select Move COPy I Unde tete I De lete 

I l-·--~ 

Figure 2-25. Arc Element 

You need to save your drawing for the advanced tutorial in 
Section 3, where you will add some new twists to the de
sign. Press the DONE key to return to the Main Menu. The 
pencil drawing disappears. 

From the Main Menu, PICK the SAVE function. DR Draw 
prompts 

5:PENCIL? (or type new naMe) 

If you want to save the picture file on this drive and with 
this name, press the RETURN key. DR Draw prompts 

5:PENCIL: savin~ file 
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EXIT DR Draw 
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If you want to save the picture file on another drive, type 
the new drive identifier, a colon, and the filename. For 
example, 

('}:PENCIL 

Then press the RETURN key. 

When the prompt disappears, DR Draw has saved the pic
ture file on diskette. You return to the Main Menu. 

If you wish to print the PENCIL picture, refer to the print 
instructions in "Print Pi~ture" in this tutorial. 

Congratulations, you have completed the first tutorial. If 
you want to leave DR Draw, PICK the EXIT function. The 
operating system prompt signals your return to the operat
ing system. If you want to review what you have learned, 
try the tutorial again. If you are ready to learn new DR 
Draw functions, turn to Section 3. In its advanced tutorial, 
you learn DR Draw functions that let you 

• SELECT a new current element 

• SCALE element size 

• ZOOM in on parts of the drawing surface 

• PAN across the drawing surface 

• adjust the relationship of overlapping design elements 
with the PUT TO BACK function 

End of Section 2 
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ADVANCED TUTORIAL 

INTRODUCTION 

RECALL THE 
PI CTURE FILE 

Building on concepts learned in Section 2, you learn in this 
tutorial how to do the following: 

• pan across the drawing surface 

• change the style for LINES 

• zoom full 
• select a new current element 

• zoom out from the drawing surface 

• zoom in on the drawing surface 

• scale an element 
• use PUT TO BACK to change the relationship of over-

lapping design elements 

First you will add more boxes to the organizational chart 
you created in Section 2. Next you will use DR Draw to 
enhance the pencil drawing you created. 

Begin by displaying your original picture file of the organi
zational chart. From the Main Menu, PICK the RECALL 
function. DR Draw displays one of two prompts 

If you exited from DR Draw after completing the Getting 
Started tutorial, you see the prompt: 

Picture filenaMe? 

If you did not exit, DR Draw retains the name of the last 
file you saved, and you see the prompt: 

B:PENCIL? (or type new naMe) 
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PAN 

DR Draw User's Guide 

In either case, to recall the file CHART, type the drive 
identifier and filename: 

B:CHART 

Press the RETURN key. DR Draw prompts 

6:CHART: reading' file 

The organizational chart appears on the screen, along with 
the Edit Menu. 

The PAN function allows you to move the window frame 
horizontally, vertically, or diagonally across the drawing 
surface. In this way, you can add design elements to areas 
of the drawing surface that are not currently inside the 
window frame. 

P.ICK the CHANGE function from the Edit Menu. From 
the Change Submenu, PICK the VIEW function. The View 
Submenu appears under the Edit Menu. 

PICK the PAN function. DR Draw indicates the center of 
the window with intersecting horizontal and vertical lines. 
You see the prompt 

PICK new center of window 

Starting at the center of the window (the intersection of the 
two lines), move the cursor 10 grid points to the left, then 
down 1 grid point. PICK the point. DR Draw redraws the 
chart with the point you PICKed now at the center. 
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Figure 3-1. Chart, Pan Left 
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COpy 
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Now you want to add more boxes to the chart. You can do 
this by copying one of the existing boxes. The extent mark
ing the current element encloses the upper box of the chart. 
To copy that element, PICK the COPY function from the 
Edit Menu. DR Draw prompts 

PICK reference point 

Move the cursor to the upper left corner of the extent. 
PICK the point. DR Draw tells you 

PICK location(s) t press DONE to finish 

Starting from the reference point you PICKed, move the 
cursor down 14 grid points, then 4 grid points to the left. 
PICK this point. A new box appears on the drawing sur
face. 
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DR Draw User's Guide 

To add another box to the chart, start from the upper left 
corner of the new current element, and move the cursor 12 
grid points to the left. PICK the point. Another box 
appears. 
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Figure 3-3. Second New Box 
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Figure 3-4. Third New Box 
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ADD AND CHANGE 
TEXT 
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Your new boxes need to be labeled. First make the grid 
more dense by using the functions you learned in "Change 
Grid Size" in Section 2. 

After you have changed the grid, PICK the ADD function 
from the Edit Menu. When the Add Submenu appears, 
PICK the TEXT design element. DR Draw prompts 

PICK startt typet RETURN; DONE finishes 

Move the cursor to the lower left corner of the last box. 
Move the cursor up 3 grid points, then 4 grid points to the 
right. PICK the point, and type 

TINA GANZ 

in the box. Press the RETURN key to end the text string. 
Press the DONE key to finish entering text and return to 
the Edit Menu. 
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Figure 3-5. Label In Box 
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The text you entered differs from the text in the original 
boxes. When you saved the CHART picture file, the cur
rent text style reverted to the machine font. 

To change the font style to Simplex Roman, PICK the 
CHANGE function from the Edit Menu. From the Change 
Submenu, PICK the STYLE function. The menu of font 
styles appears. 

PI CK the Simplex submenu selection. The name TINA 
GANZ appears in the font Simplex Roman. 

Now add a title to the box. PICK the ADD function from the 
Edit Menu. PICK the TEXT design element from the Add 
Submenu. Use the lower left corner of the TINA GANZ box 
as a starting point. Move the cursor 3 grid points to the right 
and up 1 grid point. PICK the point and type 

CONSULTANT 

As you type, the text appears in the machine font with the 
bouncing extent. When you press the RETURN key, the 
font Simplex Roman replaces the machine font. 

Fill in the remaining boxes, using the labels in Figure 3-6. 
Now that you have changed the text font style, all new text 
strings appear in the font Simplex Roman. Press the RE
TURN key at the end of each text string, and move the 
cursor to the point at which the next string will begin. 

You can correct typing errors with the BACKSPACE key. 
If you have already pressed the RETURN key, you can 
press the DONE key to finish entering text, then PICK the 
DELETE function to erase the string you just entered. If the 
string is not correctly located in the box, you can relocate it 
with the MOVE function. For details on the DELETE and 

. MOVE functions, refer to Section 5. 

Press the DONE key when you are finished. 

------------------------- I!IDDIGITAL RESEARCH® 

3-10 



DR Draw User's Guide Add and Change Text 

_ Change I Select I Move COPY I Uncle lete I De tete I 

: : : : : : : : : : : : : : ; : : : ; : : : ; : ; : : : : : : : : : : : : : : : : : r:-::-;~~-:~:~;;:-:-:-:l : : 
, , , , , , , , , , , , . . , , , , , . , , , , , , , , , , , , . , , , , , , , , , I ' . , . PI~e:CTOR ' , . , I ' , 

i! iii.! iii i: i i:: iii iii r ___ ~J~~---~=JJltJ~~-
, . , , , , , , , , . , , , , , , , , . , , i . , , !'I~ ,~~, . ~ ,~(;. , , I , • • • • , , • , • , , • , , . , , • , • , 

1,-:-,-:-,-:-.-:-,-:-,-:-.-:-," : : : : : I : : : M~~~~T.IN" : : : : I : : : : : : : : : : : : : : : : : : : : : : I ' , TINA. CiAN"' " .. I . , , , . 1.. ______________ ..1 . , . , . , .. , . , , , , , , , , . , .. 
" i., '" "."., •• ,'." •••.• , .. ,', .. , ..•• ,',." •••.. , I ' CONSULTANT' . , , , I ... , , .. , ... , ... , . , , , .. , ...... , .. , , , .. , ... , ' . 

L..'..:::....:.... ___ . ..:...:...:..'.J : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : : 
, io.. I.' , "'" i •• I, '" I I I I " ,I I """ 'I I 1'-' 1 I I I I ., I I " I I ", "'" , 

I ,'., I I •• I '" " ,. " I "" " •• , "'" I It. 1,1 I I '" I ., " I " ., ""1" 1 ., ','" ,.,' r-------.,,··,·" r-------.,··"'·,··, 
: : : : : : : : : : I : : JE-A~~ 'STAVR'OS' : : I : : : : : : : I : :' , ME' 6UY8U~N : I : : : : : : : : : : 
: : : ;.: : : : : : I : : ':'. SALES ... :: I : : : : : : : I : : '~6VERrI8INCt . : I : : : : : : : : : : 
: : : :.: : : : : : L. ... : .... ...:...:::..... __ . ..:.,.'..:... . .J : : : : : : : L·..:.,.:~:..:-=-::.:3...:...:.J : : : : : : : : : : 

Figure 3-6. Labeled Boxes 
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ADD LINES 
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Now use the LINES design element to join the new boxes 
to the rest of the chart. First make the grid less dense. PICK 
the CHANGE function from the Edit Menu. From the 
Change Submenu, PICK the GRID function, then PICK the 
SIZE 2X function from the Grid Submenu. A sparser grid 
returns to the drawing surface. 

Now PICK the ADD function from the Edit Menu. When 
the Add Submenu appears, PICK the LINES design ele
ment. DR Draw prompts 

PICK pointst press DONE when finished 

Locate the cursor at the upper left corner of the box labeled 
HUME CLAYBURN. Move the cursor 4 grid points to the 
right and PICK. 

Move the cursor up 2 grid points and PICK again. DR 
Draw draws a line between the two points. 

Now move the cursor 6 grid points to the left and PICK. 
Move the cursor up 2 grid points and PICK again. Two 
boxes are joined. 

To join these boxes to the SALES box, retrace the last line 
segment by moving the cursor down 2 grid points and 
PICKing. Now move the cursor 6 grid points to the left and 
PICK again. 

Finally, move the cursor down 2 grid points and PICK. 
Press the DONE key. The cursor disappears and the extent 
appears around the line. 
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Figure 3-7. Lines Added 

Add Lines 
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Now join the CONSULTANT box to the rest of the chart. 
You need to start the line from the center of the box's right 
edge. To do this, you can make the grid more dense, or use 
SNAP OFF to turn the SNAP off, allowing you to PICK a 
point between grid points. 

PICK the CHANGE function from the Edit Menu. From 
the Change Submenu, PICK the GRID function. When the 
Grid Submenu appears, PICK the SNAP OFF function. 
When the Grid Submenu disappears and the Edit Menu 
returns, DR Draw has turned off the SNAP. 

Now add the final line to the organizational chart. PICK 
the ADD function from the Edit Menu. From the Add 
Submenu, PICK the LINES design element. DR Draw 
prompts 

PICK pointst press DONE when finished 

Center the cursor on the right edge of the box labeled 
CONSULTANT. If you are using the keyboard arrow 
keys, you can locate the cursor more easily by changing to 
the slow cursor speed. The vertical part of the cross hair 
disappears when the cursor is positioned directly over the 
line. See Figure 3-8. PICK the point. 
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Crlange I Se leet I Move COPY Undelete I Delete 
ress DoNE when flnlshed 

1-------1 
1 ' 'DAVE 'M ITRE' , 1 

1 ' 'ol~E'CTO~' , I 
---T--~ 

._~ . .-____ ----L-~~-
I, NANC'f Te::N~ ,I 

1------1 I, 'M,~~KC:TI~Ci' , I 
1 'm~A'CiANZ "_'_' L--T ---

'CQN3I:.1LT.~N'r ' , , , , , , " "'," 

L----
r 

.-! i . ~~r ·l~~1 
1 'J~N S'rAVROS' 1 1 'HUME CU,1"SI:.IRN 1 

, 'SALES' , , I L' 'ADVERTISING ' I L __ + ___ ~ ______ ~ 

Figure 3-8. Cursor Position (Adding Lines) 

Now move the cursor horizontally to the right, and center 
it over the line descending from the box labeled MARKET
ING. PICK the point. Press the DONE key. The cursor 
disappears, and the new extent marks the line as the cur
rent element. 

Return to the GRID function and turn the SNAP function 
back on before continuing. 
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CHANGE LINE STYLE In an organizational chart, a broken line often indicates an 
indirect relationship. To illustrate such a relationship, 
change the style of the line you just added to the chart. 

LAYOUT AND 
ZOOM FULL 

ADD A TITLE 

PICK the CHANGE function from the Edit Menu. From 
the Change Submenu, PICK the STYLE function. 

PICK the dotted line, the third style in the menu. The 
dotted line replaces the solid line. 

Now you are ready to use the LAYOUT and VIEW func
tions to prepare the picture file for output. 

Use the LAYOUT function to ready the organizational 
chart for output to a screen, printer, or plotter. 

PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the LAYOUT func
tion. Next PICK the LANDSCAPE layout from the Layout 
Submenu. The LANDSCAPE layout appears on the draw
ing surface. 

Now use the ZOOM FULL function to fit the picture file 
into the layout. 

From the Edit Menu, PICK the CHANGE function. When 
the Change Submenu appears, PICK the VIEW function. 
The View Submenu appears below the Edit Menu. 

PICK the ZOOM FULL function. DR Draw redraws and 
reduces the organizational chart so that it fits in the layout. 

Use the TEXT design element to add TUNNEY ELEC
TRONICS CORPORATION to the chart. Position the title 
above and to the left of the box labeled DAVE MITRE, 
and keep the title within the layout. 
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SAVE 

REPORT COVER 
DESIGN 

RECALL PICTURE 
FILE 

SAVE 

Now that your chart is complete, you can save it for future 
editing, viewing, or output. Press the DONE key to return 
to the Main Menu. When the Main Menu appears, PICK 
the SAVE function. DR Draw prompts 

B:CHART? (or type new naMe) 

Enter a new filename so that the original picture file, 
CHART, will be available for practice. Type 

B:CHIJRT3 

and press the RETURN key. 

You can, if you wish, continue this tutorial when DR Draw 
finishes saving the file on diskette. 

However, if you want to take a break from the tutorial, 
you can PICK the EXIT function from the Main Menu to 
return to the operating system. 

Now use some new DR Draw functions to enhance the 
pencil design you created in Section 2. You could use such 
a design as a report cover. 

If you need help restarting DR Draw, refer to the Supple
ment for instructions. 

From the Main Menu, PICK the RECALL function. DR 
Draw displays one of two prompts. 

If you exited from DR Draw, you see the prompt: 

Picture filenaMe? 

If you did not exit, DR Draw retains the name of the last 
file you saved, and you see the prompt: 

B:CHART3? (or type new naMe) 
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Recall Picture File 

_ Chang~ 
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In either case, to recall the file PENCIL, type the drive 
identifier and filename: 

B:PENCIL 

Press the RETURN key. DR Draw displays the message 

B:PENCIL: reading' file 

After a pause, the picture of the pencil appears on the 
screen. 

Se\~d Move COPy Und~\ete I Delete 

-_ .. ------._":"' -:' -.- ~.~ 

·1 

.J 

Figure 3-9. PENCIL Picture File 

------------------------- IiIDDIGITAL RESEARCH® 

3-18 



DR Draw User's Guide DELETE and SELECT 

DELETE AND SELECT To begin changing the picture, delete the CIRCLE and 
ARC design elements from the drawing. 

The extent surrounds the circle, so you can delete the ele
ment easily. 

PICK the DELETE function from the Edit Menu. The circle 
disappears, and the extent appears around the triangle. An 
area of the pencil body corresponding to the circle outline 
also disappears. If you wish, redraw the picture as you 
learned in Section 2. 

Now you want to DELETE the arc that forms the pencil's 
eraser. Because you can only DELETE the current element, 
you must SELECT the arc as the new current element. For 
more information on the current element, turn to 
Section 4. 

PICK the SELECT function from the Main Menu. DR 
Draw prompts 

PICK corner of rectan9'le 

Move the cursor to a point slightly above and to the left of 
the arc. PICK the point. A pair of intersecting lines 
appears. DR Draw prompts 

PICK oppos i te co rne r of rectan 9'1 e 

Move the cursor to a point slightly below and to the right 
of the arc. PICK the point. Another pair of intersecting 
lines appears. See Figure 3-10. DR Draw prompts 

PICK Moues second corner. DONE finishes 

DR Draw lets you change the second corner if the two 
pairs of intersecting lines do not enclose the element you 
are selecting. For more information on selecting a current 
element, see the SELECT function in Section 5. 
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Figure 3-10. Pairs of Intersecting Lines Around Arc 

If you are satisfied with the rectangle, press the DONE key. 
The extent appears around the arc, which indicates that the 
arc is now the current element. 

PICK the DELETE function from the Main Menu. DR 
Draw removes the arc from the drawing surface. The ex
tent appears around the bar, which you drew just before 
the arc. The bar is now the current element. 
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ZOOM OUT 

CHANGE ELEMENT 
SCALE 

ZOOM OUT 

Now you are going to make the pencil longer. First, you 
need more room on the drawing surface. You can use the 
ZOOM OUT function to make available a larger portion 
of the drawing surface in the window frame. 

PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the VIEW function. 
The View Submenu appears below the Edit Menu. PICK 
the ZOOM OUT function. DR Draw reduces the grid and 
the design elements. The effect is similar to stepping back 
from the picture. 

To lengthen the pencil, you need to change the dimensions 
of the pencil body. PICK the CHANGE function from the 
Edit Menu. When the Change Submenu appears, PICK the 
SCALE function. Below the Edit Menu, DR Draw offers 
two options for changing element size, UNIFORM and 
NON-UNIFORM. UNIFORM changes the element size 
without changing the proportions of the element. NON
UNIFORM changes the element's proportions as well as 
its size. 

Because you want to change the width of the bar but retain 
the height, PICK the NON-UNIFORM function. DR Draw 
prompts 

PICK corner of new extent 

Move the cursor to the grid point marking the upper left 
corner of the bar. If necessary, use the cursor speed key to 
slow the cursor. PICK the point. A pair of intersecting lines 
appears. DR Draw prompts 

PICK opposite corner of new extent 
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_ Change 
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Move the cursor to the grid point"tnarking the lower right 
corner of the bar, then move 6 grid points to the right. 
PICK the point. Another pair of intersecting lines appears. 
The two pairs of lines show you how the pencil body will 
look after it is stretched. DR Draw now prompts 

PICK Moves second corner, DONE finishes 

This prompt allows you to relocate the second point and. 
define a different shape. In this case, because you are satis
fied with the second point's location, press the DONE key. 
DR Draw erases the bar and redraws it in the new shape. 

Se ted I Move Copu I Undelete I Delete 

Figure 3-11. Redrawn Bar 
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ADD BORDER 

Add Border 

Now ADD a decorative border to the picture. If your sys
tem has color capability, try changing the color of the new 
elements as you add them to the picture. 

First, make the grid less dense. From the Edit Menu, PICK 
the CHANGE function. PICK the GRID function from the 
Change Submenu. When the Grid Submenu appears, PICK 
the SIZE 2X function. The current grid disappears and a 
new, less dense grid appears on the drawing surface. 

Now use the BAR design element to draw part of the bor
der. PICK the ADD function from the Edit Menu. From the 
Add Submenu, PICK the BAR design element. DR Draw 
prompts 

PICK corner of bar 

Mo~e the cursor to the first grid point in the top row. See 
Figure 3-12. PICK the point. 
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Figure 3-12. Cursor Position (Adding Border) 
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j' 

DR Draw displays another prompt 

PICK opposite corner of bar 

Add Border 

Move the cursor down 2 grid points, then 2 grid points to 
the right. PICK the point. A square bar appears. 

Figure 3-13. First Bar 

I!ID DIGITAL RESEARCH® ---------------------------

3-25 



Add Border DR Draw User's Guide 

Now add three more squares to the picture by PICKing the 
COpy function from the Edit Menu. DR Draw prompts 

PICK refe renee PO i nt 

Locate the cursor on the grid point that marks the lower 
right corner of the current element. PICK the point. DR 
Draw prompts 

PICK loeation(s) t press DONE to finish 

Starting from the point you PICKed, move the cursor 
straight down 11 grid points and PICK. A copy of the bar 
appears. 

Figure 3-14. Second Bar 
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To add the final two bars shown in Figure 3-15, first move 
the cursor to the grid point on the right end of the same 
row. PICK again. A third bar appears. 

Then move the cursor straight up the right edge of the 
window to the third row from the top. PICK this point. 
The last bar appears. Press the DONE key to finish 
copying. 

Figure 3-15. Four Corner Bars 
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Now use the LINES design element to complete the picture 
border. PICK the ADD function from the Edit Menu. 
When the Add Submenu appears, PICK the LINES design 
element. DR Draw prompts 

PICK pointst press DONE when finished 

Add two rectangles to the border using the LINES design 
element. Look at Figure 3-16 for reference. PICK the upper 
right corner of the square at the top right of the window. 
To draw the border, do the following: 

1. Move the cursor left to the upper left corner of the first 
square, and PICK. 

2. Move the cursor down to the bottom left corner of the 
second square, and PICK. 

3. Move the cursor right to the bottom right corner of the 
third square, and PICK. 

4. Move the cursor up to the bottom right corner of the 
fourth square, and PICK. 

Now move the cursor to the inside corners of each square, 
PICKing each point as you go, until you return to the 
fourth square. Press the DONE key when the two rectan
gles are complete. 
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ZOOM IN 

Add Border 

Figure 3-16. Complete Border 

You have added a border to the pencil picture using some 
familiar functions. Now you use a new DR Draw function 
to add more design elements to the pencil. 

The ZOOM IN function allows you to enlarge part of the 
drawing surface. With ZOOM IN, you can make detail 
changes in the picture or examine elements more closely. 
Here, you will ZOOM IN on the tapered part of the pencil 
between the point and the bar that makes up the pencil's 
main body. 
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PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the VIEW function. 
From the View Submenu, PICK the ZOOM IN function. 
DR Draw prompts 

PICK corner of window 

DR Draw is asking you to define the part of the drawing 
surface you wish to fill the window. From the upper left 
corner of the inner border rectangle, move the cursor down 
1 grid point and 1 grid point to the right. PICK the point. 
Two lines intersect at the point. DR Draw prompts 

PICK opposite corner of window 

Figure 3-17. Pairs of Intersecting Lines (ZOOM IN) 
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Using the point where the lines intersect as a starting point, 
move the cursor down 6 grid points, then 4 grid points to 
the right. PICK the point. Another pair of intersecting lines 
appears on the screen, and DR Draw prompts 

PICK Moves second corner, DONE finishes 

The rectangle defined by the two pairs of intersecting lines 
shows the area that will be enlarged to fill the new window 
frame. Press the DONE key. 

DR Draw redraws the picture, and enlarges the part of the 
drawing surface you PICKed so that it fills the window 
frame. Notice that the grid points are now considerably 
farther apart on the drawing surface. 

To work in detail you can make the grid more dense. PICK 
the CHANGE function from the Edit Menu. When the 
Change Submenu appears, PICK the GRID function. 

From the Grid Submenu, PICK the SIZE O.5X function. 
DR Draw replaces the current grid with a denser grid. The 
new grid is still not dense enough to perform the detailed 
work you will be doing. Repeat the steps above, and again 
PICK the SIZE O.5X function from the Grid Submenu. 

Figure 3-18 shows the drawing surface after you ZOOM 
IN and make the grid more dense. You are now ready to 
add some new elements to the pencil. 
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ADD THREE ARCS 
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Figure 3-18. New Window Frame 

Now use the ARC design element to draw three arcs where 
the pencil body begins to taper down to the point. Use 
Figures 3-19a through 3-19d as a guide. Use FILLED arcs. 
If you need to review the ARC design element, refer to 
"Arcs" in Section 2, or to the description of the ARC 
design element in Section 6. Use the DELETE function if 
you make a mistake drawing any of the arcs. 
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Figure 3-19a. First Arc 

Add Three Arcs 

arc center (first point) 
arc radius (second point) 
end of arc (third point) 
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Figure 3-19b. Second Arc 

DR Draw User's Guide 

rc center (first point) 
radius (second point) 

'---4>n d of arc (third point) 
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Figure 3-19c. Third Arc 

Add Three Arcs 

arc center (first point) 
arc radius (second point) 
end of arc (third point) 
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Figure 3-19d. Three Arcs 

After you add the three arcs to the picture, you can look at 
the entire picture by using the ZOOM FULL function. 

PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the VIEW function. 
From View Submenu, PICK the ZOOM FULL function. 
DR Draw redraws the picture, fitting all the design ele
ments into the window frame. Because the current layout is 
SCREEN, the default layout, the picture fills the entire 
window frame. 

Notice that the grid is very dense. Before continuing, use 
the SIZE 2X function of the Grid Submenu to make the 
grid less dense. 
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BACKGROUND 
ELEMENT 

Background Element 

If you want to use a design element as a background for the 
pencil, the ADD and VIEW functions permit you to do 
this. 

First, draw the background element. Use the BAR design 
element to draw a solid rectangle over the inner rectangle 
surrounding the pencil. PICK the upper right and lower left 
corners of the rectangle so the bar will have the same 
dimensions as the rectangle. The bar element appears in 
solid fill, blocking the pencil from view. 

Figure 3-20. Bar Covers Pencil 
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CHANGE STYLE 
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The new bar has the same fill style as the pencil body. Next 
contrast the two elements by changing the fill style of the 
new bar. 

PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the STYLE function. 
The Style Submenu appears. 

PICK the fourth style from the left. DR Draw fills the bar 
with the style fill pattern you have chosen and returns you 
to the Edit Menu. 

Figure 3-21. New Bar Style 

------------------------- i!IDDIGITAL RESEARCH® 

3-38 



DR Draw User's Guide 

PUT TO BACK 

PUT TO BACK 

Now you can place the new bar behind the pencil. 

PICK the CHANGE function from the Edit Menu. When 
the Change Submenu appears, PICK the VIEW function. 
PICK the PUT TO BACK function from the View Sub-
menu. 

When DR Draw redraws the picture, it places the current 
element, the new bar, on the drawing surface first, then 
draws the other design elements. The pencil is now visible, 
and the current element is in the background. 

Figure 3-22. Bar Put To Back 
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ADD TITLE 
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To complete your picture, add a title to the report cover. 

To begin, make some room for the title by using the 
ZOOM OUT function. PICK the CHANGE function from 
the Edit Menu. When the Edit Menu appears, PICK the 
VIEW function. From the View Submenu, PICK the 
ZOOM OUT function. DR Draw reduces the picture. 

From the Edit Menu, PICK the ADD function. PICK the 
TEXT design element from the Add Submenu and type 
under the picture 

MOUNT/UN PENCILS ANNUAL SALES 

Using the CHANGE and STYLE function, PICK the Sim
plex submenu selection. The text appears in the font Sim
plex Roman. Use the MOVE function to center the title 
beneath the picture. See Figure 3-23. Your design is com
plete. If you want to change the layout of the picture, do so 
now before you save the picture. 
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Figure 3-23. Complete Picture 
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SAVE THE DRAWING To save the picture file on the diskette, press the DONE 
key to return to the Main Menu. PICK the SAVE function 
from the Main Menu. DR Draw prompts 

B:PENCIL? (or type new naMe) 

Press the RETURN key, or type a new filename and press 
the RETURN key. In the first case, DR Draw displays the 
message 

B:PENCIL: savin. file 

When the message disappears, DR Draw has saved the file 
on diskette. You can now use the OUTPUT function to 
display your drawing on the screen or to produce output 
on a printer, plotter, or camera. Otherwise, you can leave 
DR Draw by PICKing the EXIT function from the Main 
Menu. The operating system prompt appears to signal 
your return to the operating system. 

Congratulations, you have completed the advanced tuto
rial and learned some sophisticated DR Draw functions in 
the process. These tutorials, together with Sections 4, 5, 
and 6, enable you to develop your skills further with DR 
Draw. 

End of Section 3 
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CONCEPTS 

INTRODUCTION 

DR Draw MENUS 

By working through the tutorials in Sections 2 and 3, you 
learned the essentials of creating and editing pictures with 
DR Draw. This section describes the following DR Draw 
concepts: 

• DR Draw menus 
• the drawing surface 
• cursors 
• the current element 
• style 
• filenames 
• active picture files 
• picture file diskettes 

DR Draw's menus contain functions and design elements. 
The menus appear in two lines across the top of the display 
screen. The Main Menu and the Edit Menu appear at dif
ferent times in the top line. Submenus, prompts, and mes
sages appear in the second menu line; all are described later 
in this section. 
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Main Menu Functions 

DR Draw User's Guide 

When you start a session in DR Draw, the Main Menu 
appears in the top menu line. The line below it is empty. 
The Main Menu contains seven functions. 

Figure 4-1. Main Menu Functions 

Using the Main Menu functions, you can 

• create a new picture file 

• recall an existing picture file 

• edit a picture file that you create or recall 

• save a picture file 

• display a directory of picture files 

• produce output from a picture file 

• exit DR Draw and return to the operating system 

Section 5 describes all Main Menu functions. 
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Edit Menu 

r 
Change 

DR Draw Menus 

You must be in the EDIT function to draw a new picture or 
make changes to an existing picture file. When you PICK 
the CREATE or RECALL function and give a valid 
filename, you automatically pass to the EDIT function. 
Filenames are discussed in detail later in this section. 

When you are in the EDIT function, the Edit Menu re
places the Main Menu in the first line. The line below it is 
empty. The Edit Menu contains the following seven func
tions. 

se'\ed Move COPY 

Figure 4-2. Edit Menu 

With the Edit Menu functions, you can 

• add design elements to a picture file 

• change the characteristics of individual design elements 
or of the DR Draw environment 

• select a new current element 

• move a design element 

• copy a design element 

• undelete a deleted design element 

• delete a design element 

Section 5 describes all Edit Menu functions. Section 6 de
scribes design elements, which you add by PICKing the 
ADD function. 
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Submenus 

Prompts and 
Messages 

Error Messages 

DR Draw User's Guide 

Two Main Menu functions, EDIT and OUTPUT, have 
submenus that appear on the second menu line. Contents 
of the submenus include functions, design elements, and 
other choices that supply DR Draw with necessary addi
tional information. 

For example, if you PICK the ADD function from the Edit 
Menu, you need to tell DR Draw which of the seven design 
elements to add. The Add Submenu lists the seven and 
allows you to PICK one of them. 

DR Draw uses prompts to give you instructions and to 
request information from you. Prompts appear in the 
second menu line in place of submenus. 

Some prompts require that you type a response. The re
sponse appears on the second line immediately following 
the prompt. 

In addition, DR Draw displays a variety of informational 
and error messages, most of which also appear on the 
second line. 

DR Draw displays error messages when it encounters 
problems that prevent it from proceeding as requested. 
Error messages briefly describe the problem and give you 
instructions on what to do next. 

In Section 5, the description of each function lists the error 
messages associated with the function and describes the 
cause of the error. 
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DRAWING SURFACE 

Drawing Surface 

The drawing surface is two-dimensional. It is visible inside 
a rectangle located just below the menu lines, as Figure 4-3 
illustrates. The drawing surface is visible only when you 
are in the EDIT function; at other times that part of the 
screen is empty. 

Figure 4-3. Drawing Surface 

menu 
submenu 

drawing surface 
L-----grid 

!lID DIGITAL RESEARCH® ---------------------------

4-5 



Drawing Surface 

Window and Window 
Frame 

Grid and Snap 
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The display screen acts as a window to the drawing sur
face; the rectangular outline is the window frame. 

You control how much of the picture file is visible in the 
window frame. If design elements are outside the window 
frame, they are still part of the picture file, but they are not 
visible. With the VIEW function described in Section 5, 
you can 

• move the window over the drawing surface to 

-look at other parts of your picture file 

- add or modify design elements 

• zoom in on the drawing surface for a more detailed 
VIew 

• zoom out for a broader view 

• fit the entire picture file into an output layout 

When you begin a new picture file, the drawing surface is 
filled with a grid of evenly spaced points that help you 
locate and align design elements. 

To help you locate design elements, DR Draw automatical
ly snaps to the nearest grid point when you PICK a point 
on the drawing surface. 

The GRID function, described in Section 5, allows you to 
turn the grid and snap off when you do not wish to use the 
points for alignment. 
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CURSORS 

Menu Cursor 

Input 
Device 

keyboard 

mouse 

Cursors 

Cursors mark your position in the menus and on the draw
ing surface. DR Draw uses three cursors: a menu cursor, a 
graphics cursor, and a text cursor. 

The menu cursor marks your position on one of the menu 
lines. To PICK a function or design element, move the 
menu cursor to the correct position and press the PICK 
key. 

The menu cursor can be a reverse video bar or a cross hair 
(+), depending on your computer. 

Reverse video describes the appearance of characters 
against the display's background color. For example, a 
screen that ordinarily shows light characters on a dark 
background indicates the cursor's position in reverse video 
by showing dark characters on a light background. 

You do not have to place the cross hair directly on top of 
the menu. To PICK a function or design element, you can 
locate the cursor on or below your choice and press the 
PICK key. 

The menu cursor's operation varies from keyboard to 
mouse. Table 4-1 outlines these differences. 

Table 4-1. Menu Cursor 

Cursor Movement 
Left-Right Right-Left 

TAB BACKSPACE 

mouse movement 

PICK 

SPACEBAR 

PICK key 

DONE 

RETURN 
. . 
DONE key 
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Menu Cursor: 
Wrapping 

Graphics Cursor 

Graphics Cursor: 
Range of Motion 

Graphics Cursor: 
Mouse 

Graphics Cursor: 
Keyboard 

DR Draw User's Guide 

In keyboard operation, the reverse video bar cursor wraps 
in both directions. Wrap means that if you advance the 
cursor past one end of the menu, it reappears at the other 
end of the menu. 

For example, if you press the TAB key when the Edit Menu 
cursor is on the DELETE function, the cursor appears on 
the ADD function. Similarly, if you press the BACKSPACE 
key when the cursor is on the ADD function, the cursor 
appears on the DELETE function. 

The graphics cursor appears after you PICK any of the Edit 
Menu functions but DELETE or UNDELETE. The 
graphics cursor is a cross hair; its center marks your posi
tion on the drawing surface. 

The graphics cursor can move anywhere on the drawing 
surface inside the window, but you cannot move the cursor 
beyond the window frame. 

If you use a mouse to move the graphics cursor, the cursor 
echoes the mouse's movement. If you need further in
formation on the mouse, consult the documentation sup
plied with it. 

With a keyboard, you use the four arrow keys to move the 
graphics cursor up and down and left and right. To move 
the cursor diagonally, you combine vertical and horizontal 
cursor movements. To move the cursor continuously, hold 
down the arrow key that is moving the cursor. 
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Graphics Cursor: 
Speed and Distance 

Text Cursor 

CURRENT ELEMENT 

Cursors 

You can move the cursor rapidly or slowly. The fast speed 
corresponds to a large cursor movement each time you 
press the arrow key; the slow speed corresponds to a short 
movement. One of the keys on your keyboard allows you 
to reduce the cursor's speed and distance. The same key 
allows you to return the cursor to its original speed and 
distance. The key is identified in the Supplement or the 
documentation that accompanied your computer system. 

The text cursor marks the location of characters you type 
from the keyboard. The cursor is an underscore. You see 
the text cursor at two different times during a DR Draw 
work session. 

1. When you PICK the TEXT design element from the 
Add Submenu and then PICK a point for entering text, 
the text cursor appears on the drawing surface. Section 
6 describes the TEXT design element. 

2. When a prompt requires that you type a response, the 
text cursor appears on the second menu line im
mediately following the prompt. 

To draw pictures with DR Draw, you PICK design ele
ments from the Add Submenu. One design element in the 
picture file is called the current element. The current ele
ment is defined as one of the following: 

• the most recently added element in a picture file you are 
working on 

• the first-drawn element when you recall a picture file 

• an element that you explicitly select as the current ele
ment 

The MOVE, COPY, and DELETE functions, as well as 
several of the CHANGE functions, affect only the current 
element. 
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Extent 
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The current element is surrounded by a rectangular dashed 
line called the extent. Figure 4-4 shows you the current 
element and the extent. 

r----------------- --j current 
element 

extent 

• 
Shared Extents 

Figure 4-4. Current Element and Extent 

If two or more elements share the same extent (for exam
ple, a circle inscribed in a square), the first-drawn element 
is the current element whenever you select the shared ex
tent. 

For more information on selecting a current element, see 
the SELECT function in Section 5. 
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STYLE 

Initial Style 

Changing Style 

Style 

A design element can have one of four style attributes: 

• type style 
• line style 
• fill pattern 
• marker style 

The style that DR Draw assigns to each design element 
when you create a new picture file or recall an existing one 
is called its initial style. Table 4-2 lists the attributes and 
initial styles for each design element. 

Table 4-2. Initial Styles 

Design Element Attribute Initial Style 

TEXT type style machine font 
POLYGON fill pattern solid fill 
OPEN CIRCLE line style solid line 
FILLED CIRCLE fill pattern solid fill 
OPEN ARC line style solid line 
FILLED ARC fill pattern solid fill 
LINES line style solid line 
BAR fill pattern solid fill 

Using the STYLE function described in Section 5, you can 
change a design element's style. For example, you can 
change machine font text to one of three other fonts, and 
you can change the solid line of an open arc to one of 
several other line styles. 
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Design Elements 
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When you change an element's style, you establish a cur
rent style that replaces the initial style. From that point on, 
all elements that share the attribute of the element you 
changed appear in the current style. For example, if you 
change the fill in a bar, the new fill pattern appears in all 
subsequent bars, and also in polygons, filled circles, and 
filled arcs. 

The current style 

• only affects elements in your current picture file 

• does not affect any elements added before you changed 
style 

• remains in effect until the next time you change style or 
until you save the file 

When you save or recall a file, DR Draw resets the style to 
the iriitial style. Elements already in the picture file are not 
changed, but all new elements appear in their initial styles 
until you change the style. 

An open design element consists of straight or curved lines. 
The space enclosed by the lines has nothing in it. 

A filled design element consists of straight or curved lines 
with a pattern inside. Fill patterns include solid fill, cross 
hatching, and the hollow fill described below. 

You can make CIRCLE and ARC design elements either 
OPEN or FILLED when you draw them. POLYGON and 
BAR design elements are always filled. Shapes drawn with 
LINES are always open. 
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Hollow Fill 

Style 

The hollow fill pattern produces an element that looks like 
an open element. You see the difference when you overlay 
elements. 

When you draw an open element on top of another ele
ment, you can see the element underneath. If you do the 
same with a hollow-filled element, the hollow fill masks the 
element it overlaps. Figure 4-5 illustrates the difference 
between an open element and one with hollow fill. 

open circle circle with 
hollow fill 

Figure 4-5. Hollow Fill 
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FILENAMES 

Illegal Characters 

Filetype 
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When you PICK the CREATE, OUTPUT, RECALL, and 
SAVE functions, DR Draw asks you to supply a filename. 
Filenames identify picture files for you, DR Draw, and the 
operating system. The filename you select must be unique; 
you cannot have two picture files with the same filename 
on the same diskette. 

The filename can be any combination of letters and num
bers that does not exceed eight characters. DR Draw 
ignores anything after the eighth character. The alphabetic 
characters can be uppercase, lowercase, or both. 

Do not use the following characters in a filename: 

<> = ,!I'~?&/$[]() + -

Some operating systems and applications reserve these 
characters for special purposes. 

In addition, do not use spaces in filenames. DR Draw 
ignores spaces. 

After you supply the filename, DR Draw adds a .PIX 
filetype. For example, the filename CHART becomes 
CHART. PIX. The filetype identifies the file as a DR Draw 
picture file. Do not give a .PIX filetype to a file that you did 
not create with DR Draw. 

If you include a period as part of the filename, as in the 
example in Table 4-3, DR Draw treats the period and any 
subsequent characters as an invalid filetype. DR Draw dis
cards the invalid filetype and supplies .PIX in its place. 
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Filename Typed 

flow 

orgchart 

organization 

org.plan 

ACTIVE PICTURE 
FILES 

Created and 
Recalled Files 

Abandoning an 
Active File 

Table 4-3. Filenames 

Filename Used 

flow. pix 

orgchart. pix 

organiza. pix 

org.plx 

Explanation 

valid as given 

, valid as given 

too many characters 

period in filename 

Filenames 

For additional information on specifying filenames, consult 
your operating system manual. 

The picture file you are working on in the EDIT function is 
called your active picture file; it is like a sheet of drawing 
paper you spread on your desk or table. 

If you create a new picture file, the active file is the only 
existing version of your picture file; no previous version is 
stored on diskette. 

If you recall an existing picture file, the active file is a copy 
of the file you recalled. The original version remains on 
diskette until you replace it by saving the active file under 
the same name. 

For more information, see the descriptions of the 
CREATE, RECALL, and SAVE functions in Section 5. 

If you PICK the CREATE, RECALL, OUTPUT, or EXIT 
function without saving your active picture file, DR Draw 
displays the prompt 

Abandon active picture file? (YIN) 
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Disk Drive 
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Disk Drive 
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An N (No) response returns you to the Main Menu and 
allows you to save the file. A Y (Yes) response abandons 
your active picture file, which is like tearing up the sheet of 
drawing paper and discarding the pieces in the wastebas
ket. You no longer have an active file. 

Unless you specify otherwise, DR Draw saves picture files 
on the same diskette that contains DR Draw. You can, 
however, save your picture files on a separate diskette to 
give you more room for file storage and to make it easier 
for you to identify your DR Draw picture files. 

The disk drive identifier, a letter from A to P followed by a 
colon, identifies the drive in which your diskette is located. 

If you use a separate picture file diskette, you must identify 
the drive when you give a picture filename. For example, if 
DR Draw is on the diskette in drive A and you want a file 
called FLORPLAN on the diskette in drive B, type 

f3:FLORPUW 

to any DR Draw prompt that requests a filename. 

When you specify a separate picture file diskette, DR Draw 
includes the disk drive identifier in messages. For example, 
if you use the SAVE function to save the file called FLOR
PLAN on the diskette in drive B, DR Draw displays the 
message 

B:FLORPLAN: sauin~ file 

End of Section 4 
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Section 5 

FUNCTIONS 

INTRODUCTION This section describes in alphabetical order the functions 
contained in the Main Menu, Edit Menu, and Change Sub
menu. Section 6 describes the design elements contained in 
the Add Submenu. 

The Main and Edit Menus are illustrated at the beginning 
of Section 4. The Main Menu contains seven functions: 

• CREATE 
• DIRECTORY 
• EDIT 
• EXIT 
• OUTPUT 
• RECALL 
• SAVE 

The Edit Menu also contains seven functions: 

• ADD 
• CHANGE 
• COpy 
• DELETE 
• MOVE 
• SELECT 
• UNDELETE 
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Change Submenu 

Prompts 

Error Messages 

DR Draw User's Guide 

When you PICK the CHANGE function from the Edit 
Menu, the Change Submenu appears on the second line. 
The Change Submenu contains seven functions. 

• COLOR 
• GRID 
• LAYOUT 
• REDRAW 
• SCALE 
• STYLE 
• VIEW 

After you PICK a function, DR Draw in many cases dis
plays prompts that ask for needed information or that in
struct you how to proceed. 

When a function has two or more prompts, you respond to 
one prompt before DR Draw displays the next. The de
scriptions of the functions reflect this sequence by follow
ing the text of each prompt with a description of how you 
respond. 

As outlined in Section 4, DR Draw displays error messages 
when it encounters problems that prevent it from proceed
ing as requested. 

In several cases functions have two or more error messages 
associated with them. In that case, the description of the 
function gives each error message, its cause, and your re
sponse. 

-------------------------- i!IDDlGITAL RESEARCH® 

5-2 



DR Draw User's Guide 

ADD 

Purpose 

Add Submenu 

ADD 

The ADD function lets you PICK design elements to add to 
your picture file. 

When you PICK the ADD function from the Edit Menu, 
the Add Submenu appears on the second menu line, as 
Figure 5-1 illustrates. If your menu cursor is a reverse video 
bar, it appears on the second menu line. If your menu 
cursor is a cross hair, it appears on the drawing surface. 
Section 4 describes menu cursors. 

The Add Submenu contains seven design elements, which 
are described in Section 6. 

Figure 5-1. Edit Menu and Add Submenu 
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CHANGE 

Purpose 
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The CHANGE function lets you change 

• the style of design elements 

• the view of the picture file in the window 

• the scale (size and/or proportions) of design elements 

• the layout used for output 

• the color of design elements 

• the grid's characteristics 

and redraw the active picture file. 

When you PICK the CHANGE function from the Edit 
Menu, the Change Submenu appears on the second menu 
line, as Figure 5-2 illustrates. If your menu cursor is a 
reverse video bar, it appears on the second menu line. If 
your menu cursor is a cross hair, it appears on the drawing 
surface. Section 4 describes menu cursors. 

The Change Submenu contains seven functions. Descrip
tions of these appear alphabetically in this section. 

Figure 5-2. Change Submenu 
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COLOR 

Purpose 

Sample Color File 

COLOR 

The COLOR function lets you change the color of the 
current element. 

When you PICK the COLOR function from the Change 
Submenu, the Color Submenu replaces the Change Sub
menu on the second line. The Color Submenu lists eight 
colors, in rectangles numbered 0 through 7. If your menu 
cursor is a reverse video bar, a small rectangle marks your 
position on the Color Submenu. If your menu cursor is a 
cross hair, it appears on the drawing surface. Section 4 
describes menu cursors. 

The appearance of the Color Submenu depends on the 
display you have. On color display monitors, the menu 
rectangles appear in the color represented by the number. 
For example, if color number 2 is red, the number 2 rec
tangle has a red fill in addition to the number. 

Some color monitors, printers, and plotters do not support 
all eight colors. To learn which colors are represented by 
the numbers on the menu, create a picture file with eight 
bars. Number the bars from 0 to 7, and change the color of 
each one to the corresponding color. You can save and 
print the file for quick reference. 
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COpy 

Purpose 

Prompts 

Reference Points 
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The COpy function copies the current element to locations 
you choose on the drawing surface. 

When you PICK the COpy function, DR Draw displays 
two prompts in the sequence below. 

PICK reference point 

PICK a reference point on or near the extent. Reference 
points are described below. 

In many cases a corner of the extent is the easiest point to 
use as a reference point. 

PICK locatiords) t press DDNE to finish 

Move the cursor to the reference point's new location and 
press the PICK key. DR Draw copies the element to the 
new location. Each additional PICK copies the element to 
another location. Each new copy of the element becomes 
the current element. Press the DONE key to return to the 
Edit Menu. 

The COpy function divides the extent into nine invisible 
sectors, as Figure 5 -3 illustrates. All except the middle sec
tor (number 5) extend infinitely beyond the extent. 

A design element has nine reference points, which are 
marked in Figure 5-3: the corners of the extent, the mid
point of each side of the extent, and the center of the 
extent. If, for example, you PICK a point anywhere in 
sector number 4, DR Draw uses the midpoint of the left 
side of the extent as the reference point. 
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2 3 

4 6 

7 8 9 

Figure 5-3. Reference Points 
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CREATE 

Purpose 

Prompt 

Error Messages 

DR Draw User's Guide 

The CREATE function permits you to begin a new picture 
file. DR Draw opens an active picture file under the name 
you supply. 

PICKing the CREATE function is like the following: 

• going to the cabinet where you store your drawings 

• making a space for the new drawing by writing a 
filename on an empty folder 

• returning to your drawing table 

• setting a fresh sheet of drawing paper in front of you 

DR Draw displays the following prompt when you PICK 
the CREATE function. 

Picture filenaMe? 

When you give a filename, DR Draw checks your directory 
to be sure that filename does not already exist with a .PIX 
filetype. If the file is not found, DR Draw automatically 
places you in the EDIT function, and you can start draw
mg. 

You can receive one of two error messages when you PICK 
the CREATE function. One error message is 

CHART: already existst press DONE 

You gave a filename (in this case, CHART) that is already 
in your directory with a .PIX filetype. Press the DONE key 
to return to the Main Menu. To begin a new picture file, 
PICK the CREATE function again and give a new filename. 
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The other error message is 

Abandon active picture file? (YIN) 

You PICKed the CREATE function without saving your 
active picture file. DR Draw displays this error message 
instead of the prompt. 

If you respond Y (Yes), DR Draw abandons the active 
picture file and prompts 

Picture filenaMe? 

Section 4 discusses abandoning an active picture file. 

If you respond N (No), DR Draw returns you to the Main 
Menu. To continue working on your active picture file, 
PICK the EDIT function. To save the active file, PICK the 
SA VE function. 
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The DELETE function removes the current element from 
your picture file. 

You delete design elements strictly by the order in which 
you added them, starting with the current element and 
working backwards in sequence until you reach the first 
element in the picture file. If design elements remain after 
the first-drawn element is deleted, DELETE works forward 
In sequence. 

Each time you delete an element, the next element in the 
sequence becomes the current element. 

The five design elements in Figure 5-4 were added to the 
file in the order indicated by the numbers. If you start with 
the star as the current element, DELETE works in the se
quence 5-4-3-2-l. 

However, if you start with the arc as current element, the· 
sequence is 3-2-1-4-5. 

You can delete an element that is not inside the window 
frame. For example, in Figure 5-4, if you ZOOM IN until 
only the bar is visible, you can still delete the star, arc, 
circle, and square. 

Deleting an element that overlaps another also removes 
from the drawing surface (but does not delete) some or all 
of the element underneath. For example, when you delete 
the circle in Figure 5-4, a circular hole appears in the 
square. 

In addition, if you delete any element from the drawing 
surface when the grid is on, the grid points under the ele
ment are also deleted. 

To restore the missing parts of an element or missing grid 
points, use the REDRAW function described later in this 
section. 
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1 

~2 3 
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! 

1 5 

Figure 5-4. Deleting Elements 
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The DIRECTORY function lists all files with a .PIX 
filetype on the diskette in a drive you specify. 

While you are using the EDIT function, you can look at the 
directory without affecting work in progress. 

When you PICK the DIRECTORY function, DR Draw dis
plays the following prompt. 

Give the disk drive's identifier, a letter from A to P. As soon 
as DR Draw displays the directory, the Main Menu reap
pears. The directory display remains on the screen until 
you do one of the following: 

• PICK the CREATE, RECALL, or OUTPUT function 
and give a valid filename 

• PICK the EDIT function to return to an active picture 
file 

• PICK the SAVE function to save an active picture file 

• PICK the DIRECTORY or EXIT function 

If you do not give a drive identifier in response to the 
DIRECTORY prompt, DR Draw returns you to the Main 
Menu. 

You can receive the following error message when you 
PICK the DIRECTORY function. 

No PIX files on diskt press DONE 

No .PIX files are on the drive specified. Press the DONE 
key to return to the Main Menu. 
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EDIT 

Purpose 

Edit Menu 

_ ChanQe 

Error Message 

EDIT 

The EDIT function lets you draw, update, and modify pic
ture files. 

When you PICK the CREATE or RECALL function and 
give a correct filename, DR Draw automatically places you 
in the EDIT function. 

If you return to the Main Menu while editing a picture file, 
you can PICK the EDIT function to resume work on your 
active file. There are two common reasons for returning to 
the Main Menu in the middle of work~ng on a picture file: 

• You wanted to check the directory. 
• You accidentally pressed the DONE key. 

The Edit Menu replaces the Main Menu on the first menu 
line. The Edit Menu lists the seven functions shown in 
Figure 5-5. 

Select Move COPY Undelete I Delete 

Figure 5-5. Edit Menu 

You can receive the following error message when you 
PICK the EDIT function. 

No active picture filet press DONE 

You PICKed the EDIT function, but you do not have an 
active picture file. Press the DONE key to return to the 
Main Menu. 
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The EXIT function lets you leave DR Draw and return to 
the operating system. 

You can receive the following error message when. you 
PICK the EXIT function. 

Abandon active picture file? (YIN) 

You PICKed the EXIT function without saving your active 
picture file. 

If you respond Y (Yes), DR Draw abandons the active 
picture file and returns you to the operating system 
prompt. Section 4 discusses abandoning an active picture 
file. 

If you respond N (No), DR Draw returns you to the Main 
Menu. To continue working on your active picture file, 
PICK the EDIT function. To save the active file, PICK the 
SA VE function. 
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GRID 

Purpose 

GRID 

The GRID function allows you to change the appearance 
or function of the drawing grid. 

When you PICK the GRID function from the Change Sub
menu, the Grid Submenu replaces the Change Submenu on 
the second line. If your menu cursor is a reverse video bar, 
it remains on the second menu line. If your menu cursor is 
a cross hair, it appears on the drawing surface. Section 4 
discusses menu cursors. 

Depending on the status of GRID and SNAP, three differ
ent Grid Submenus can appear. In its initial state, the Grid 
Submenu has four functions. 

Grid I Size 2X I Size O.5X I Snap Off 

Figure 5-6a. Grid Submenu - GRID On and SNAP On 

GRID OFF 

SIZE 2X 

Message 

When you PICK the GRID function with the grid visible, 
DR Draw turns off the grid, which removes the points 
from the drawing surface. At the same time, DR Draw 
automatically turns off the snap. 

When you PICK the SIZE 2X function, DR Draw redraws 
the grid with the points twice as far apart as in the present 
grid; the grid becomes half as dense. SIZE 2X does not 
affect the size of elements in your picture file. 

You can receive the following message when you PICK the 
SIZE 2X function. 

Cannot show sridt press DONE 

Using the SIZE 2X function, you made the grid points so 
far apart that DR Draw turns the grid off and reports its 
status to you. You have not made an error; you can leave 
the grid off if you want. 
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You can make the grid more dense with the SIZE O.5X, 
ZOOM OUT, or ZOOM FULL functions. However, if you 
use one of the ZOOM functions, you must PICK the GRID 
function to make the grid visible again. 

When you PICK the SIZE O.5X function, DR Draw re
draws the grid with the points half as far apart as in the 
present grid; the grid becomes twice as dense. SIZE O.5X 
does not affect the size of elements in your picture file. 

You can receive the following message when you PICK the 
SIZE O.5X function. 

Cannot show fridt press DONE 

Using the SIZE O.5X function, you made the grid too dense 
to be visible as individual points. DR Draw turns the grid 
off and reports its status to you. You have not made an 
error; you can leave the grid off if you want. 

You can make the grid less dense with the SIZE 2X and 
ZOOM IN functions. However, if you use the ZOOM IN 
function, you must PICK the GRID function to make the 
grid visible again. 

When you PICK the SNAP OFF function, DR Draw turns 
the grid snap off. For more details on SNAP, refer to Sec
tion 4. 

When the snap is off, you can PICK the cursor's exact 
location on the drawing surface. The cursor does not snap 
to the nearest grid point. 

The Grid Submenu changes according to the current status 
of GRID and SNAP. 

You see the following submenu after you turn off the grid. 

Grid I Size 2X I Size O.5X I 
Figure 5-6b. Grid Submenu - GRID Off and SNAP Off 
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GRID ON 

Third Submenu 

GRID 

When you PICK the GRID function with the grid not visi
ble, DR Draw turns the grid on and restores the points to 
the drawing surface. 

Because DR Draw automatically turned off the snap when 
you turned off the grid, no SNAP function appears on this 
submenu. You cannot turn the snap on when the grid is 
off. 

You see the following submenu when you turn the snap off 
but leave the grid on. 

Grid I Size 2X I Size O.5X Snap On 

Figure 5-6c. Grid Submenu - GRID On and SNAP Off 

SNAP ON 

When the snap is turned off, DR Draw PICKs the cursor's 
exact location on the drawing surface. The cursor does not 
snap to the nearest grid point. 

Turning off the snap is particularly useful when you are 
entering text strings inside boxes. For example, in the 
Menu Map at the beginning of this user's guide (Figure 
1-2), the menu rectangles were drawn using the LINES 
design element with the snap turned on. The text strings 
were inserted in the boxes with the snap turned off. 

When you PICK the SNAP ON function, DR Draw turns 
the snap on. 
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The LAYOUT function tells DR Draw which output for
mat to use when you send your picture file to the screen, 
printer, or plotter. Only the part of the picture file within 
the layout appears in output. 

When you PICK the LAYOUT function from the Change 
Submenu, the Layout Submenu replaces the Change Sub
menu on the second line. If your menu cursor is a reverse 
video bar, it remains on the second menu line. If your menu 
cursor is a cross hair, it appears on the drawing surface. 
Section 4 describes menu cursors. 

The Layout Submenu contains three layout formats. 

Portrait ILandscapel Screen 

Figure 5-7. Layout Submenu 

PORTRAIT is the format of a vertical sheet of standard 
letter-size paper, 8 112-inches wide by ii-inches high. A 
rectangular outline on the drawing surface shows you the 
PORTRAIT layout boundaries. 

LANDSCAPE is the format of a sheet of horizontal paper, 
8 1I2-inches high by ii-inches wide. A rectangular outline 
on the drawing surface shows you the LANDSCAPE lay
out boundaries. 

SCREEN format uses the entire drawing surface; the win
dow frame is the layout boundary. When you PICK the 
CREATE function, DR Draw automatically places you in 
SCREEN layout. 
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LAYOUT 

PORTRAIT 

El 

LANDSCAPE 

SCREEN 

LAYOUT 

Figure 5-8 shows the relationship of layout to output. 

PRINTER or PLanER 
OUTPUT 

Figure 5-8. Layout to Output 

SCREEN 
OUTPUT 
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The MOVE function allows you to relocate the current 
element to another position on the drawing surface. 

When you PICK the MOVE function, DR Draw displays 
two prompts in the sequence below. 

PICK reference point 

PICK a reference point on or near the element's extent. 
Reference points are described under the COpy function. 

In many cases a corner of the extent is the easiest point to 
use. 

PICK new location, press DONE to finish 

Move the cursor to the reference point's new location any
where on the drawing surface and PICK that point. DR 
Draw deletes the element from its current position and 
redraws it at the new location. 

If you are not satisfied with the element's location, you can 
PICK another point. Again, DR Draw deletes the element 
and redraws it in the new location. When you are satisfied 
with the location, press the DONE key to return to the Edit 
Menu. 
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OUTPUT 

Purpose 

Output Submenu 

Printer 

Printer/Plotter 

Screen lIScreen 2 

Camera 

OUTPUT 

The OUTPUT function sends your picture file to one of 
four output devices. 

When you PICK the OUTPUT function, the Output Sub
menu appears on the second menu line. The Output Sub
menu lists the five possible output devices in the order 
shown below. If your menu cursor is a reverse video bar, it 
appears on the second menu line. If your menu cursor is a 
cross hair, it appears on the drawing surface. Section 4 
describes menu cursors. 

Plotter I Screen 11Screen 21 Camera 

Figure 5-9. Output Submenu 

You can send your picture file to be printed on printer or 
plotter paper or on transparencies. If you specify a printer 
or plotter, DR Draw prints or plots a single copy of the 
picture file, then returns you to the Main Menu. 

You can send your picture file to a black and white screen 
or to a color screen if you have the necessary equipment 
and software. For more information, refer to the Supple
ment. 

DR Draw reproduces your picture file on a display screen 
without the window frame, layout lines, grid points, or 
menu lines. 

To return to the Main Menu from screen output, press the 
DONE key. 

You can send your picture file to a camera output device to 
make prints or slides. DR Draw transmits the picture file to 
the camera device and then returns you to the Main Menu. 

For more information on camera output, consult the docu
mentation that came with the output device. 
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Prompt 

Output Time 

Error Messages 

DR Draw User's Guide 

DR Draw displays one of two prompts after you PICK an 
output device. 

Picture filenaMe? 

Type the filename after the prompt. If the filename is valid, 
DR Draw sends the picture file to the output device you 
PICKed. 

CHART? (or type new naMe) 

In this case, you have been working on a picture file called 
CHART. PIX and have either just saved or abandoned the 
file. 

If you have saved the file, this prompt allows you to pro
duce output by pressing the RETURN key. 

If you have abandoned the file, this prompt allows you to 
produce output from the existing version of the file by 
pressing the RETURN key. 

In either case, this prompt also allows you to type a differ
ent filename and produce output from another picture file. 

DR Draw requires time to process a picture file for output. 
The amount of preparation time depends on the number 
and types of design elements in the file. Do not worry if the 
output does not appear immediately. 

You can receive one of two error messages when you PICK 
the OUTPUT function. One error message is 

Abandon actil.!e picture file? (YIN) 

You PICKed the OUTPUT function without saving your 
active picture file. DR Draw displays this message instead 
of the Output Submenu. 

If you respond Y (Yes), DR Draw abandons your active 
picture file and displays the Output Submenu. Section 4 
discusses abandoning an active picture file. 

If you respond N (No), you return to the Main Menu. 
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The other error message is 

CHART: not found, press DONE 

OUTPUT 

DR Draw cannot find the file you named (in this case, 
CHART). Press the DONE key to return to the Main 
Menu. 

Check to see that you included a correct drive identifier, if 
one is required. The drive identifier appears in the message 
only if you gave it in your response to the filename prompt. 

This message also appears when you do the following: 

1. create a new picture file called CHART, but do not 
save it 

2. PICK the OUTPUT function. DR Draw displays the 
"Abandon active picture file?" prompt. 

3. abandon the active picture file. DR Draw displays the 
prompt 

CHART? (or type new naMe) 

4. press the RETURN key 

DR Draw displays the error message because no file called 
CHART exists. 
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RECALL 

Purpose 

Prompt 
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The RECALL function lets you retrieve a picture file that 
you saved. DR Draw opens an active picture file by 
copying the file stored on your diskette. The original re
mains on the diskette unless you replace it with the SAVE 
function. 

PICKing the RECALL function is like the following: 

• going to the cabinet where you store your drawings 

• taking out a drawing 

• making a photocopy of the drawing 

• returning the original to the storage cabinet 

• putting the copy on your drawing table 

DR Draw displays one of two prompts when you PICK the 
RECALL function. One prompt is 

Picture filenaMe? 

Respond by typing the filename. For example, type 
CHART. You do not need to give the .PIX filetype; DR 
Draw searches only for files with that filetype. 

If the file is in your directory, you see the following mes
sage: 

CHART: reading file 

DR Draw displays the picture file and automatically places 
you in the EDIT function. You can then begin work on the 
file. 

The other prompt is 

CHART? (or type new naMe) 

This prompt indicates that you have been working on a 
picture file called CHART. PIX and have either just saved 
or abandoned the file. 
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Reading Files 

Current Element 

Retained 
Attributes 

Error Messages 

RECALL 

If you have saved the file, this prompt allows you to recall 
it by pressing the RETURN key. 

If you have abandoned the file, this prompt allows you to 
recall the existing version of the file by pressing the RE
TURN key. 

In either case, the prompt also allows you to type a differ
ent filename and recall another picture file. 

If the file is in your directory, you see the message: 

CHART: reading file 

DR Draw displays the picture file and automatically places 
you in the ED IT function. You can then begin work on the 
file. 

The amount of time DR Draw needs to read your file will 
vary, depending on the number and types of design ele
ments in the file. For example, circles take longer to read 
than bars. 

When you RECALL a file, the current element is always the 
first design element that you added when you began the 
file. 

The following attributes of the recalled picture file are re
tained from the last time you worked on the file: 

• the location of the window on the drawing surface 

• the layout 
• the status of GRID and SNAP 

You can receive one of three error messages when you 
PI CK the RECALL function. One error message is 

CHART: not foundt press DONE 

You gave a filename (in this case, CHART) that is not on 
the diskette. If you give a drive identifier as part of the 
filename, DR Draw includes it in the message. 
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Press the DONE key to return to the Main Menu. To recall 
a picture file, PICK the RECALL function again and give 
another filename. 

This message also appears when you do the following: 

1. create a new picture file called CHART, but do not 
save it 

2. PICK the RECALL function. DR Draw displays the 
"Abandon active picture file?" prompt. 

3. abandon the active picture file. DR Draw displays the 
prompt 

CHART? (or type new naMe) 

4. press the RETURN key 

DR Draw displays the error message because no file called 
CHART exists. 

The second error message is 

Abandon active picture file? (YIN) 

You PICKed the RECALL function without saving your 
active picture file. DR Draw displays this error message 
instead of the prompt. 

If you respond Y (Yes), DR Draw abandons the active 
picture file and prompts 

Picture filenaMe? 

or 

CHART? (or type new naMe) 

Section 4 discusses abandoning an active picture file. 

If you respond N (No), DR Draw returns you to the Main 
Menu. To continue working on your active picture file, 
PICK the EDIT function. To save the active file, PICK the 
SAVE function. 
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The third error message is 

CHART: incorrect forMatt press DONE 

DR Draw displays this message in several situations. 

1. You gave a .PIX filetype to a file that was not created 
with DR Draw. DR Draw cannot read the file. You 
can avoid this situation by not combining picture files 
and other files on the same diskette. 

2. Your computer lost power when you were saving a 
file. You find the file in your directory the next time 
you start your computer, but the file is missing in
formation that DR Draw needs in order to read it 
successfully. 

3. There is a problem with the diskette from which you 
are trying to recall the file. The diskette might need to 
be reformatted, in which case all files on the diskette 
are lost. However, you might be able to save some of 
the files if you copy the diskette before you reformat it. 
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REDRAW 

Purpose 
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The RED RAW function lets you 

• see your picture file in its current state 
• redraw the grid 

Several of the EDIT functions, especially DELETE and 
MOVE, can alter the appearance of design elements or the 
grid. 

For example, if you place a polygon on top of a circle, the 
polygon masks some or all of the circle. If you delete the 
polygon, you cannot see the masked part of the circle until 
you use the REDRAW function. 

Similarly, when the grid is on, moving an element deletes 
the grid points under the element's original position. Use 
the REDRAW function to restore the grid. 

When the REDRAW is complete, DR Draw returns you to 
the Edit Menu. 
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SAVE 

Purpose 

Created Files 

Recalled Files 

SAVE 

The SAVE function stores your active picture file on a 
diskette. When you save a file, you can 

• retain the file's original name 
• rename the file 

The descriptions of the CREATE and RECALL functions 
use the analogy of a storage cabinet where you keep your 
pictures. With the SAVE function the analogy takes one of 
two forms, depending on whether you created or recalled 
the file. 

When you create a file, you write the file's name on an 
empty folder in your storage cabinet. When you save a file 
under its original name, you go over to the cabinet and slip 
the picture into its folder. When you rename the file, you 
change the name on the folder before putting the picture 
inside. 

When you recall a file, the original stays in the folder in the 
storage cabinet. You work on a copy. 

Saving the file under its original name is like going to the 
folder, destroying the original, and replacing it with the 
new verSIOn. 

When you rename the file, you go to the cabinet and open 
up a new folder. The new version of the file, bearing the· 
new name, goes into the new folder. The old version re
mains in the cabinet under its original name. 
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Prompt 

Error Message 
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DR Draw displays the following prompt when you PICK 
the SA VE function. 

CHART? (or type new naMe) 

Press the RETURN key to save the file under its original 
name (in this example, CHART). To save the file under a 
new name, type the new name before you press the RE
TURN key. 

DR Draw displays one of these messages while the file is 
being saved: 

CHART: s a v in It f i I e 

or 

NEWNAME: savinlt file 

You can receive one of two error messages when you PICK 
the SA VE function. 

No active picture filet press DONE 

You PICKed the SAVE function without having an active 
picture file. Press the DONE key to return to the Main 
Menu. 

CHART: already existst press DONE 

To rename the file, you gave the name of a file that is 
already on the diskette with a .PIX filetype. Press the 
DONE key to return to the Main Menu. 
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SCALE 

Purpose 

PICK a New Extent 

Changing 
Proportions 

Moving Elements 
with SCALE 

SCALE: Text 

Prompts 

SCALE 

The SCALE function lets you 

• enlarge or reduce stroke font text 

• enlarge, reduce, or change the proportions of elements 
other than text 

The SCALE function affects only the current element. 

You tell DR Draw how much to enlarge or reduce the 
current element by PICKing the opposite corners of a rec
tangle that becomes the element's new extent. 

For all design elements but text, you can change the ele
ment's proportions. For example, you can use SCALE to 
change a circle to an oval. . 

The new extent that you define can be anywhere inside the 
window frame. You can, for example, use SCALE to 
change a large circle in the upper left corner of the drawing 
surface to a small oval in the lower right corner. 

When you PICK the SCALE function to enlarge or reduce 
the size of stroke font characters, DR Draw displays three 
prompts in the sequence below. 

PICK corner of new extent 

Move the cursor to a point on the drawing surface and 
PICK the first corner of the new text extent. Unless you 
want to move the string at the same time, you can use the 
same point that you PICKed when you first entered the 
string. When you PICK the point, DR Draw extends verti
cal and horizontal lines to show you two sides of the ex
tent. 

PICK opposite corner of new extent 

Move the cursor diagonally and PICK the opposite corner 
of the new extent. 
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DR Draw extends a second set of vertical and horizontal 
lines. For the reasons given below, the intersection of the 
two lines might not be the point you PICKed. Figure 5-10 
illustrates how the two points can differ. 

Chief Executive Officer 

"'---- PICI( u;" point; ~ 
--DR Draw displO'jS these lines 

-- PICK this point 

~ 
p DR Draw displays these lines 

Chief Executive Officer 

-----------------------------------------------------~ DR Draw scales the string 
to this size C_hj_eJ ___ E_~~_~_uti'f_~ ___ Qffj_(_~[l 

Figure 5-10. Scaling Text 

You can change the size of stroke font characters but not 
their proportions. The two points you PICK define a rec
tangle into which DR Draw tries to fit the text string. The 
lines that DR Draw displays indicate the best fit of the 
string in the rectangle you defined. 

The lines that DR Draw displays are an accurate indicator 
of the string's new size and shape. 

PICK Moves second cornert DONE finishes 

If you are not satisfied with the size of the extent, you can 
move the cursor and PICK a new second point. 

When you press the DONE key, DR Draw redraws the text 
string in the new size and returns you to the Edit Menu. 
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Error Message 

SCALE: Non-Text 
Elements 

SCALE 

You can receive the following error message when you 
PICK the SCALE function. 

Cannot SCALE Machine font. press DONE 

You tried to SCALE machine font characters. The size of 
machine font characters cannot be changed. 

The SCALE function lets you enlarge, reduce, or change 
the proportions of POLYGON, CIRCLE, ARC, LINES, or 
MARKERS design elements. 

When you PICK the SCALE function with a non-text cur
rent element, DR Draw displays a submenu that gives you 
the option of retaining or changing the element's propor
tions. 

Uniform Non-Uniform 

Figure 5-11. Scale Submenu 

UNIFORM retains the element's proportions. The result
ing element is larger or smaller than the original, but it is 
the same shape. 

NON-UNIFORM changes the element's proportions. In 
addition to being larger or smaller than the original, the 
resulting element is a different shape. 

Figure 5-11 illustrates how SCALE works on text, mark
ers, and a polygon. 
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original 
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Scaling Markers 

uniform 

ri5t~----Drawl 
~ ..... __ ............................. ____ ... ____ oJ 
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. . .......... ___ .......... __________ ............ __ ..... J 
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non-uniform 

(text cannot be scaled 

non-uniformly) 

------------------ ....... - --- --- ---.., . , 

.' . , .. -- ---- .. -- -- --- ...... -- -- .................. .. 

Figure 5-12. SCALE Example 

Markers are a special case. Because they are machine font 
characters, you cannot scale single markers. You can, 
however, scale markers that you entered in a group. DR 
Draw changes the distance between the markers without 
changing the size of the markers. For more details on 
markers, refer to Section 6. 
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Prompts 

Error Message 

SCALE 

After you PICK the SCALE function, DR Draw displays 
three prompts in the sequence below. 

PICK corner of new extent 

Move the cursor to a point on the drawing surface and 
PICK one corner of the new extent. When you PICK the 
point, DR Draw extends vertical and horizontal lines to 
show you two sides of the extent. 

PICK opposite corner of new extent 

Move the cursor diagonally and PICK the opposite corner 
of the new extent. DR Draw again extends vertical and 
horizontal lines. The rectangle formed by the intersection 
of the four lines allows you to preview the new extent. 

PICK Moues second corner, DONE finishes 

If you are not satisfied with the size and/or shape of the 
extent, you can move the cursor and PICK a new second 
point. 

When you press the DONE key, DR Draw redraws the 
element to fit the new extent, then returns you to the Edit 
Menu. 

You can receive the following error message when you 
PI CK the SCALE function. 

Cannot SCALE this eleMent, press DONE 

DR Draw displays this error message in two situations. 

1. You tried to scale a single marker. Because a marker is 
a machine character, you cannot change its size. 

2. You tried to scale an element that is so small that DR 
Draw thinks it is a single point. This unusual situation 
can arise when you zoom out many times. 
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SELECT 

Purpose 

SELECT Rectangle 
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The SELECT function lets you choose a new current ele
ment from among the elements on the drawing surface. 

You select a current element by PICKing two points that 
mark the opposite corners of a rectangle. This rectangle 
must do one of the following: 

• enclose the entire design element 

• enclose one corner of the extent around the design ele-
ment 

• enclose one vertex of any design element except TEXT 

Figure 5-13 illustrates the three ways you can select a cur
rent element. The second part of the figure, "enclose corner 
of extent," shows the extents around the two elements. 
The extent is not visible when you PICK the SELECT func
tion, but is shown here for purposes of illustration. 

1. enclose entire element 2. enclose corner 
of extent 

3. enclose vertex 
(except text) 

Figure 5-13. Selecting a Current Element 
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Design Element 
Vertex 

open arc 

SELECT 

With the exception of the center of a circle or open arc, a 
vertex is any point you PICK while drawing a circle, arc, 
polygon, line, or group of markers. In addition, almost any 
point on the curved line of an arc or circle can be a vertex. 
The black circles in Figure 5-14 identify the vertices for 
each element. 

filled arc 

lines 

Figure 5-14. Vertices 

8 8 
markers 

8 

Figure 5-14 does not include a bar, because the vertices for 
the BAR design element are the same as the corners of the 
element's extent. 
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How SELECT Works 
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Following the prompts described below, PICK the opposite 
corners of the SELECT rectangle. DR Draw looks at the 
part of the picture file inside the rectangle and follows this 
series of steps: 

1. If the rectangle entirely enclos~s a design element, DR 
Draw selects· it as the current· element. 

If the rectangle encloses more than one design element, 
DR Draw selects the first'-drawn. 

If the rectangle does not entirely enclose a design ele
ment, DR Draw passes to the next step. 

2. If the rectangle encloses the corner of the extent 
around a design element, DR Draw selects it as the 
current element. 

If the rectangle encloses the corner of more than one 
extent, DR Draw selects the first-drawn. 

If the rectangle does not enclose the corner of an ex
tent, DR Draw passes to the next step. 

3. If the rectangle encloses a vertex of an arc, circle, line, 
or polygon, or if it encloses a single marker in a group 
of markers, DR Draw selects that element as the cur
rent element. Figure 5-15 shows how you can enclose a 
vertex to select a design element in a shared extent, in 
this example an octagon inscribed in a square. 

If the rectangle encloses vertices of more than one ele
ment or markers from more than one group of mark
ers, DR Draw selects the first-drawn element. 

If the rectangle does not enclose a vertex or a marker, 
DR Draw retains the present current element as cur
rent element. 
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SELECT rectangle 
surrounds this 
vertex of the 
polygon 

SELECT 

'-/'-/'-/'-/'-/'-/'-/'-/'-/'-/'-/'-/I~----- extent su rro u n d s 

I I 

M----------~ 

both design elements; 
the polygon is the 
current element 

Figure 5-15. Selecting One Element from a Shared Extent 
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Prompts 

Selecting TEXT 
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When you PICK the SELECT function from the Edit 
Menu, DR Draw displays three prompts in the sequence 
below. 

PICK corner of rectangle 

Move the cursor to one corner of the rectangle and PICK 
that point. DR Draw extends vertical and horizontal lines 
from the point. 

PICK opposite corner of rectangle 

Move the cursor to the rectangle's opposite corner and 
press the PICK key again. DR Draw projects vertical and 
horizontal lines from this point too. 

PICK Moves second corner, DONE finishes 

If you are not satisfied with the rectangle, you can move the 
cursor and PICK a different second corner. When you press 
the DONE key, DR Draw selects the new current element, 
draws an extent around it, and returns you to the Edit 
Menu. 

To select a text string, make the rectangle larger than you 
would for other design elements. The extent around a text 
string is somewhat larger than the characters it encloses. 
Figure 5-13 shows text in an extent. 
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STYLE 

Purpose 

Text 

The STYLE function changes the style attribute of your 
current element. Depending on the current element, the 
style attribute is one of the following: 

• type style 
• line style 
• fill pattern 
• marker style 

When you PICK the STYLE function from the Change 
Submenu, the Style Submenu replaces the Change Sub
menu on the second line. If your menu cursor is a reverse 
video bar, it remains on the second menu line. If your menu 
cursor is a cross hair, it appears on the drawing surface. 
Section 4 describes menu cursors. 

The contents of the Style Submenu depend on whether the 
current element is text, a filled element, an open element or 
a line, or markers. 

For more information on styles, refer to Section 4 and to 
the descriptions of the design elements in Section 6. 

When the current element is text, DR Draw displays the 
following Style Submenu: 

I Machine I Simplex I Complex I Italic 

Figure 5-16. Style Submenu for TEXT 

The description of the TEXT design element in Section 6 
discusses the three default fonts and the font library. 
Appendix A explains how you can replace the default fonts 
for the Complex and Italic submenu selections with fonts 
from the library. 

The initial style for text is the machine font. 
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Filled Elements 

Open Elements and 
Lines 

Markers 
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When the current element is a filled arc, filled circle, poly
gon, or bar, DR Draw displays a submenu of fill patterns. 
A small rectangle marks your position on the submenu. 
The type of computer you have determines the number of 
fill patterns in the submenu. 

Some printers or plotters might not be able to reproduce all 
the fill patterns you see on your computer. You can create a 
sample file by drawing a bar or polygon for each fill pattern 
your computer displays. Printing the file lets you see how 
the fill patterns appear in output. 

The initial style for filled elements is a solid fill. 

When the current element is an open arc, open circle, or a 
line, DR Draw displays a submenu of line styles. The type 
of computer you have determines the number of line styles 
in the submenu. 

Some printers or plotters might not be able to reproduce all 
the line styles you see on your computer . You can create a 
sample file by drawing a line for each style your computer 
displays. Printing the file lets you see how the line styles 
appear in output. 

The initial style for lines is a solid line. 

When the current element is a marker, DR Draw displays a 
submenu of five marker styles. 

Refer to the description of the MARKERS design element 
in Section 6 for more details on MARKERS. 

The initial style for MARKERS is an asterisk. 
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UNDELETE 

Purpose 

Design Element 
Order 

Error Message 

UNDELETE 

The UNDELETE function redraws the element that was 
most recently deleted from the picture file. 

DR Draw redraws the element, makes it the current ele
ment, and returns you to the Edit Menu. 

UNDELETE works only on the last deleted element; pre
viously deleted elements are lost. 

Because it redraws design elements, the UNDELETE func
tion can change the order of design elements in a picture 
file. The undeleted element becomes the newest addition to 
the picture file. 

For example, if you select the arc (number 3) in Figure 5-4, 
delete, then undelete it, the redrawn arc is element 
number 6. 

For more on design element order, refer to the description 
of the DELETE function. 

You can receive the following error message when you 
PICK the UNDELETE function. 

No deleted eleMent, press DONE 

You PICKed UNDELETE without having deleted any
thing. Press the DONE key to return to the Edit Menu. 
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VIEW 

Purpose 

Zoom In 

ZOOM IN 

Prompts 
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The VIEW function permits you to move the window over 
the drawing surface or to change design element order. 

When you PICK the VIEW function from the Change Sub
menu, the View Submenu replaces the Change Submenu on 
the second line. If your menu cursor is a reverse video bar, 
it remains on the second menu line. If your menu cursor is 
a cross hair, it appears on the drawing surface. Section 4 
describes menu cursors. 

The View Submenu lists five functions. 

Zoom Fu" I Zoom Out I Pan I Put to Back I 
Figure 5-17. View Submenu 

ZOOM IN gives you a close-up view of a portion of what 
is currently in the window. To identify what you want to 
see in close-up, you PICK the opposite corners of a rectang
le that DR Draw fits to the window frame. 

When you PICK the ZOOM IN function, DR Draw dis
plays three prompts in the sequence below. 

PICK corner of window 

PICK the first corner of the rectangle. When you press the 
PICK key, horizontal and vertical lines extend from the 
cursor's position to the window frame. 

PICK opposite corner of window 

Move the cursor diagonally to the opposite corner of the 
rectangle and press the PICK key again. A second set of 
horizontal and vertical lines extends from the cursor's posi
tion to the window frame. The rectangle formed by these 
lines gives you a preview of the area that will be enclosed 
by the window frame. 

PICK Moues second cornert DONE finishes 
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The Grid 

ZOOM FULL 

VIEW 

If you are not satisfied with the location of the second 
point, you can continue to move the cursor and press the 
PICK key. When you press the DONE key, DR Draw dis
plays the close-up by fitting the rectangle you defined to the 
window frame. DR Draw then returns you to the Edit 
Menu. 

ZOOM IN decreases the density of the grid; individual 
points are farther apart. 

ZOOM FULL fits all the elements in your picture file to the 
current layout. 

If part of the picture file is outside the layout, ZOOM 
FULL proportionally reduces the elements and the space 
between them. 

If the whole picture file is within the layout, ZOOM FULL 
proportionally enlarges the elements and the space be
tween them. 

Figure 5-16 illustrates three ways ZOOM FULL fits and 
centers the picture file in the layout. The broken-line out
lines represent picture files, which can contain any com
bination of design elements. The solid-line outlines are the 
layouts. 
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1. same proportions 

rOPI 
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ZOOM FULL E centering Figure 5-18. 3. vertical 
xample 

I!ID DIGITAL RESEARCH® 

5-46 



DR Draw User's Guide 

ZOOM OUT 

PAN 

Prompt 

PUT TO BACK 

VIEW 

In the first example, the picture file is larger than the layout 
but has the same proportions. ZOOM FULL reduces the 
picture file and fits it to the layout on all sides. 

In the second example, the proportions of the picture file 
and layout are different. ZOOM FULL reduces the picture 
file to fit the layout and centers the picture file horizontally. 

In the third example, the picture file is entirely within the 
layout but again has different proportions. ZOOM FULL 
enlarges the picture file and centers it vertically. 

ZOOM OUT reduces both the elements in the picture file 
and the space between them to two thirds their present 
size. The effect of ZOOM OUT is similar to what happens 
when you stand before a picture, then step back from it. 

ZOOM OUT also reduces the distance between grid points 
by the same amount. The grid becomes more dense. 

PAN allows you to move the picture file horizontally, verti
cally, or diagonally in the window. The effect of PAN is 
similar to what happens if you move a rectangular frame 
over a large sheet of paper. 

When you PICK the PAN function, DR Draw displays 
intersecting lines that indicate the center of the window. 

DR Draw displays the following prompt when you PICK 
the PAN function. 

PICK new center of window 

Move the cursor to a point on the drawing surface that you 
want as the new center of the window. When you press the 
PICK key, DR Draw redraws the picture file with the new 
point in the center of the window. 

PUT TO BACK changes design element order by making 
the current element the first element in the picture file. 
When elements overlap or share the same extent, you can 
use PUT TO BACK to take the element on top and put it 
underneath. 
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Figure 5-17 illustrates one use of PUT TO BACK. The 
following numbered sentences describe the three parts of 
the figure. 

1. Draw a bar, then a circle that partly overlaps the bar. 

2. Select the bar as the current element and change its fill 
pattern. The bar now overlaps the circle. 

3. Use PUT TO BACK to assign the bar to the first-drawn 
position. The circle again overlaps the bar. 

2. 3. 

Figure 5-19. PUT TO BACK Example 

The element that you PUT TO BACK remains the current 
element. 

End of Section 5 
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DESIGN ELEMENTS 

INTRODUCTION 

Add Submenu 

This section describes the seven DR Draw design elements 
in alphabetical order. 

• ARC 
• BAR 
• CIRCLE 
• LINES 
• MARKERS 
• POLYGON 
• TEXT 

When you PICK the ADD function from the Edit Menu, 
the Add Submenu appears on the second menu line. The 
Add Submenu lists DR Draw's seven design elements in the 
order shown below. If your menu cursor is a reverse video 
bar, it appears on the second menu line. If your menu 
cursor is a cross hair, it appears on the drawing surface. 
Section 4 describes menu cursors. 

Figure 6-1. Design Elements in the Add Submenu 
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Prompts 
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After you PICK a design element, DR Draw displays 
prompts that instruct you how to draw the element. 

Some design elements have two or more prompts, in which 
case you respond to one prompt before DR Draw displays 
the next. The design element descriptions list the prompts 
in the order you receive them and follow each prompt with 
a description of how you respond. 
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ARC 

Definition 

Prompts 

ARC 

An arc can be either part of the circumference of a circle (a 
curved line) or a filled pie section. 

When you PICK the ARC design element, DR Draw dis
plays three prompts in the sequence below. 

PICK arc cente r 

PICK a point on the drawing surface to be the center of the 
arc. 

PICK arc radius/beginning of arc 

PICK a second point on the drawing surface. This point 
serves two purposes: 

1. It defines the radius of the arc. 

2. It defines the beginning of the arc. If you think of an 
arc as resembling the sweep of a windshield wiper, the 
beginning of the arc is like the wiper's position at the 
start of its sweep. 

PICK end of arc 

PICK a third point to define the end of the arc. To use the 
windshield wiper analogy again, the end of the arc is like 
the wiper's position at the end of its sweep. 

Because the arc's radius is established when you PICK the 
second point, the third point can be anywhere on a line 
from the center, as Figure 6-2 illustrates. 
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Changing Style 
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" -orc radius/ 
/' beginning of arc 

(second point) 

Lore center (first poInt) 

Figure 6-2. Drawingan Arc 

After you PICK the last point, DR Draw shows you a 
submenu: 

Open Filled 

Figure 6-3. Arc Submenu 

An OPEN arc is a curved line that is part of the circumfer
ence of a circle. The initial line style is a solid line. You can 
change style to one of several other line styles. 

A FILLED arc is a pie section. The initial style for fill is 
solid. You can change the fill to one of several other pat
terns, including a hollow fill. 

For more information on changing style, see the subsection 
on STYLE in Section 4 and the description of the STYLE 
function in Section 5. 
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Drawing Arcs 

ARC 

The order in which you PICK the second and third points 
determines the appearance of the arc you draw. In both 
parts of Figure 6-4, the three points are the same, but the 
order of the second and third points is reversed. The arrow 
shows how DR Draw always starts with the second point 
and draws counterclockwise. If you PICK the sequence on 
the left, you get a pie slice. If you PICK the sequence on the 
right, you get the pie with the slice missing. 

2 

2 
.............................. 

3 

Figure 6-4. Drawing Arcs 

In addition, because the distance between points 1 and 2 is 
shorter on the right, the pie has a smaller radius than the 
slice. 
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BAR 

Definition 

Prompts 

Fill 

Changing Style 

Text in Bars 
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A bar is a filled rectangle. 

II11111111111111111111111 

When you PICK the BAR design element, DR Draw dis
plays two prompts in the sequence below. 

PICK corner of bar 

PICK a point on the drawing surface. 

PICK opposite corner of bar 

Move the cursor diagonally to the opposite corner of the 
rectangle and press the PICK key again. 

As soon as you PICK the second corner point, DR Draw 
draws the bar and returns you to the Edit Menu. 

The initial style for bars is a solid fill. You can change the 
fill to one of several other patterns, including a hollow fill. 

For more information on changing style, see the subsection 
on STYLE in Section 4 and the description of the STYLE 
function in Section 5. 

You can insert text in a bar with hollow fill, but you must 
add the text after you draw the bar. Otherwise, the hollow 
fill pattern masks the text. You can avoid this situation by 
drawing the box with the LINES design element instead. 
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CIRCLE 

Definition 

Prompts 

Submenu 

OPEN Circle 

FILLED Circle 

Changing Style 

CIRCLE 

A circle can be either a circular outline or a filled disk. 

When you PICK the CIRCLE design element, DR Draw 
displays two prompts in the sequence below. 

PICK circle center 

PICK a point on the drawing surface to be the center of the 
circle. 

PICK circle radius 

Move the cursor any direction and PICK another point to 
establish the circle's radius. 

After you PICK the second point, DR Draw shows you a 
submenu: 

Open Filled 

Figure 6-5. Circle Submenu 

An OPEN circle is a circular outline. The initial line style is 
a solid line. You can change its style to one of several other 
line styles. 

The initial fill style is a solid fill. You can change the fill to 
one of several other patterns, including a hollow fill. 

For more information on changing style, see the subsection 
on STYLE in Section 4 and the description of the STYLE 
function in Section 5. 
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Your Screen 
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Because of the resolution and aspect ratio of some display 
monitors, circles can appear slightly oval on the drawing 
surface and in screen output. However, this effect is not 
present in printer or plotter output. 
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LINES 

Definition 

, , , , 
I , , , 

I 

Prompt 

Rubberband Line 

Style 

Changing Style 

I , , , 
I , 

LINES 

The LINES design element can be a single straight line or a 
series of connected line segments. 

~ , , 

I 
When you PICK the LINES design element, DR Draw dis
plays a single prompt. 

PICK points, press DONE when finished 

PICK a starting point. Move the cursor to another point on 
the drawing surface, and PICK an endpoint. 

If you want a single straight line, press the DONE key to 
return to the Edit Menu. 

If you want a series of connected line segments, continue 
moving the cursor and pressing the PICK key. After you 
PICK the endpoint of the last line segment, press the 
DONE key to return to the Edit Menu. 

If your computer supports this feature, you can preview a 
line segment before you PICK its endpoint. DR Draw con
nects the starting point and the cursor with a line that 
stretches like a rubber band as you move the cursor over 
the drawing surface. When you are satisfied with the posi
tion of the line, PICK the endpoint. 

The initial style for lines is a solid line. You can change 
style to one of several other line styles. 

For more information on changing style, see the subsection 
on STYLE in Section 4 and the description of the STYLE 
function in Section 5. 
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Text in Boxes 

Drawing Over Lines 

LEFT 
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You can place text inside boxes drawn with lines, as in 
Figure 6-6. Unlike bars, polygons, filled circles, and filled 
arcs, shapes drawn with lines do not have a fill pattern that 
masks your text. 

You can draw over lines. For example, to draw the lines 
that connect the boxes in Figure 6-6, follow this sequence: 

• PICK a starting point on the lefthand box. 

• Move the cursor to the righthand box and PICK the 
endpoint of the first line segment. 

• Move the cursor back over the line to its midpoint and 
PICK again. 

• Move the cursor down to the lower box and PICK the 
final point. 

• Press the DONE key. 

RIGHT 

CENTER 
Figure 6-6. LINES Example 
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MARKERS 

Definition 

Prompt 

Groups of Markers 

Initial Style 

Changing Style 

Printing Markers 

Marker Size 

MARKERS 

A marker is a character that you can use to mark points, 
highlight, or accent design elements. Five marker styles are 
available. 

+ * o x 
When you PICK the MARKERS design element, DR Draw 
displays a single prompt. 

PICK pointst press DONE when finished 

To draw only one marker, move the cursor to the desired 
position on the drawing surface and press the PICK key. 
Then press the DONE key to return to the Edit Menu. 

To draw several markers, move the cursor and PICK each 
marker position before you press the DONE key to return 
to the Edit Menu. 

When you add several markers at once, DR Draw treats 
them as a single element. Functions like MOVE, COPY, 
and DELETE affect the entire group. In addition, you can
not select individual markers from a group that was en
tered together. 

The initial style for MARKERS is an asterisk. You can 
change style to one of several other marker styles. 

For more information on changing style, see the subsection 
on STYLE in Section 4 and the description of the STYLE 
function in Section 5. 

Markers are machine characters, not stroke font charac
ters. The appearance of markers on printed output depends 
on your printer or plotter. For ready reference you can 
create and print a file with samples of each marker style. 

Because markers are machine characters, you cannot scale 
them individually. You can, however, scale the extent of a 
group of markers, as Figure 5-12 illustrates. 

!lID DIGITAL RESEARCH® --------------------------

6-11 



POLYGON 

POLYGON 

Definition 

Prompt 

Rubberband Line 

Fill 

Changing Style 
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A polygon is a closed figure made up of straight line seg
ments. Closed means that the beginning point of the first 
line segment is the same as the endpoint of the final line 
segment. The figures below are all polygons. 

When you PICK the POLYGON design element, DR Draw 
displays a single prompt. 

PICK pointst press DONE when finished 

PICK a point on the drawing surface. Complete the first 
line segment by moving the cursor and PICKing another 
point. Then move the cursor and PICK points to complete 
each subsequent line segment. Complete the polygon by 
joining the first and last points. Press the DONE key to 
return to the Edit Menu. 

If your computer supports this feature, you can preview 
each line segment before you PICK its endpoint. DR Draw 
connects the starting point and the cursor with a line that 
stretches like a rubber band as you move the cursor over 
the drawing surface. When you are satisfied with the posi
tion of the line, PICK the endpoint. 

A polygon is a filled element. The initial style is a solid fill. 
You can change the fill to one of several other patterns, 
including a hollow fill. The fill pattern appears when you 
press the DONE key. 

For more information on changing style, see the subsection 
on STYLE in Section 4 and the description of the STYLE 
function in Section 5. 
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ZOOM IN and PAN 

POLYGON 

When you use ZOOM IN or PAN so that part of the 
polygon is outside the window frame, DR Draw eliminates 
the fill pattern. If you then use PAN, ZOOM FULL, or 
ZOOM OUT to bring the entire element back inside the 
window frame, DR Draw restores the fill pattern. 

For more information on these DR Draw functions, refer 
to Section 5. 
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Text Strings 

Prompt 
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A text string is a word, phrase, sentence, or any other 
group of characters and spaces you enter from the 
keyboard. 

You can use a variety of font styles from the DR Draw font 
library, which is described later in this section and in detail 
in Appendix A. Available characters include alphabetic 
and numeric characters, punctuation marks (except for the 
exclamation point), and the Greek alphabet. 

When you PICK the TEXT design element, DR Draw dis
plays a single prompt. 

PICK startt tvpet RETURN; DONE finishes 

Move the cursor to the place where you want your text 
string to begin and press the PICK key. The text cursor 
replaces the graphics cursor on the drawing surface to indi
cate where typed characters appear. 

Type the text string and press the RETURN key. 

The text cursor disappears, and the graphics cursor reap
pears one text line below the previous line. You now have 
the following options: 

• PICK the cursor's present location as a point for enter
ing text. 

• Move the cursor to a point on the same line as the 
previous string and PICK the start of a new string. 

• Move the cursor to another position on the drawing 
surface and PICK the start of a new string. 

• Press the DONE key to complete your text input and 
return to the Edit Menu. 
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RETURN Key and 
DONE Key 

Correcting Typing 
Errors 

Current Element 

Text String Length 

TEXT 

The text prompt makes a distinction between the RE
TURN key and the DONE key. They are the same key on 
your keyboard, but they are functionally different. 

When you press the RETURN/DONE key at the end of a 
text string, it functions as a RETURN key. The graphics 
cursor moves down a line, and you can enter more text. 

When you press the RETURN/DONE key again, without 
PICKing a new point for entering text, it functions as a 
DONE key. DR Draw terminates your text input and re
turns you to the Edit Menu. 

If you notice a typing error in your text string before you 
press the RETURN key, you can correct it by using the 
BACKSPACE key. Because the BACKSPACE key deletes 
characters, you have to retype the string from the point of 
the error. 

If you see the error after you press the RETURN key, use 
DELETE to erase the entire string and enter it again. 

When you enter multiple strings and press the DONE key 
to end your text input, the last string you entered becomes 
the current element. 

A single text string can be up to 79 characters long. 

However, you can enter text strings that are longer than 
the available line length on your display. For example, if 
you 

• have an 80-column display 

• start a text string anywhere after the second column 

• enter a 79-character text string 

the string extends past the right edge of the window frame. 
DR Draw handles this situation in the following manner: 

• The text cursor stops when it reaches the window 
frame. 
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• From then on, each character or space that you type 
appears in the position immediately preceding the cur
sor, as Figure 6-7 illustrates. By displaying the charac
ters in this way, DR Draw permits you to check the 
accuracy of your typing. 

• When you finish the string and press the RETURN key, 
the entire string becomes part of your active picture file. 
However, as Figure 6-7 also shows, you can only see 
the part of the string that is inside the window frame. 
You can use PAN, ZOOM OUT, or ZOOM FULL to 
bring the whole string back onto the drawing surface 
and make it fully visible. 

I 
This string is too 10._ 

characters appear here ______ --'1 
as you type 

This string is too Ion 
whot ~u see after you ~ 
press the RETURN key 

wh<Jt is on your diskette ~ 

--cursor 

--window frame 

This string is too long for your display. 

Figure 6-7. Text Too Long for the Display 
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Machine Fonts 

Stroke Fonts 

Text Style 

Font Library 

TEXT 

Machine font is the type style generated by your computer. 
The size and shape of machine font characters depend on 
the computer you are using. You cannot change the size of 
machine font text. 

Printers and plotters also have their own machine fonts 
distinct from the computer's. For that reason, you can ex
pect printed output of machine font text to be different 
from what you see on your display monitor. 

The other fonts are called stroke fonts, which means that 
they are part of the software included with the DR Draw 
package. Using the SCALE function described in Section 5, 
you can change the size of stroke font text. 

Screen and printed output of stroke font text look the 
same. 

Regardless of the current style, text appears in machine 
font as you type. If your current style for text is one of the 
stroke fonts, DR Draw displays a bouncing extent to show 
how much space the string will occupy. When you press 
the DONE key, DR Draw rewrites the string in the current 
font style. 

DR Draw offers you a library of twelve stroke fonts. Table 
6-1 lists the menu names and the defaults for the stroke 
fonts. 

Table 6-1. Default Stroke Fonts 

Menu Name 

Simplex 
Complex 
Italic 

Default Font 

Simplex Roman 
Complex Roman 
Triplex Italic 

Appendix A contains samples of all the stroke fonts and 
tells you how you can replace default fonts with others 
from the library. 
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Changing Style 

Zooming on Text 

Recommended 
Procedure 
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For more information on changing style, see the subsection 
on STYLE in Section 4 and the description of the STYLE 
function in Section 5. 

If you use ZOOM IN, ZOOM OUT, or ZOOM FULL on 
a picture file that combines machine font text and another 
element (for example, a polygon), the polygon changes in 
size, but the text does not. Zooming also changes their 
relative positions and can cause the polygon to overlap the 
text. 

When you use one of the ZOOM functions on a picture file 
that combines stroke font text and other elements, every
thing enlarges or reduces equally. The relative positions 
remain the same. 

Section 5 describes the ZOOM functions. 

You might make a practice of immediately changing 
machine font text to one of the stroke fonts. If you do, your 
printed output matches what you see on your display 
screen, and you can use the ZOOM functions without 
affecting the relationship of the design elements in your 
picture file. 

End of Section 6 
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FONT LIBRARY 

INTRODUCTION 

COpy YOUR 
DISKETTE 

PROGRAM DISKETTE 
AND DEFAULT 
FONTS 

DR Draw's font library allows you to select from 12 stroke 
fonts, including serif and sans-serif Roman fonts, as well as 
italic, script, Greek, and gothic fonts. 

The distribution diskettes that you receive with DR Draw 
include the font library diskette. Make a working copy of 
the library diskette before you use the font library. Store 
the original library diskette in a safe place in case you need 
to make copies in the future. 

The Supplement tells you how to copy a diskette. 

Your DR Draw work diskette contains three font files, 
named DRA W.BIN, FONTB.BIN, and FONTC.BIN. 
These files correspond in the following manner to the three 
stroke font selections in the Style Submenu for the TEXT 
design element: 

• If you PICK the Simplex submenu selection, DR Draw 
uses the font that is named DRAW.BIN. 

• If you PICK the Complex submenu selection, DR Draw 
uses the font that is named FONTB.BIN. 

• If you PICK the Italic submenu selection, DR Draw 
uses the font that is named FONTC.BIN. 
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When you receive DR Draw, the three font files on your 
program diskette contain DR Draw's three default fonts: 
Simplex Roman, Complex Roman, and Triplex Italic. You 
can retain the defaults, or you can replace Complex Ro
man and Triplex Italic fonts with selections from the font 
library. 

Table A-l lists the font filenames on the program diskette, 
their corresponding submenu selections, and the default 
fonts. 

Table A-1. Font Files, Submenu Selections, and Defaults 

Submenu 
Filename 

DRAW.BIN 
FONTB.BIN 
FONTC.BIN 

Selection 

Simplex 
Complex 
Italic 

Default Font 

Simplex Roman 
Complex Roman 
Triplex Italic 

For information on changing fonts, refer to "Changing 
Fonts" in this appendix. 
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FONT LIBRARY FILES The font library diskette contains twelve font files, includ
ing files for the three default fonts. Table A-2lists the fonts 
and their corresponding filenames on the font library disk
ette: 

Table A-2. Font Library Files 

Font Name Filename 

Simplex Roman SIMPROM 
Complex Roman COMROM 
Duplex Roman DUPROM 
Indexical Roman INDROM 

Triplex Italic TRIITA 
Indexical Italic INDITA 
Gothic Italic GOTITA 

Simplex Script SIMSCR 
Complex Script COMSCR 

Simplex Greek SIMGRE 
Complex Greek COMGRE 
Indexical Greek INDGRE 
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Figure A-I shows the word Draw in the four Roman fonts. 
Note that the size of the characters and the letter spacing 
differ from one font to the next. 

Draw 
Draw 

Draw 

Draw-
Figure A-1. Illustration of the Four Roman Fonts 

"Font Character Sets" in this appendix shows the full char
acter set for each font. 
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CHANGING FONTS 

STYLE SUBMENU 
FOR TEXT 

Changing Fonts 

To replace default fonts with fonts from the library, you 
must use operating system commands. 

If you are using DR Draw, return to the Main Menu, and 
PICK the EXIT function. 

When you see the operating system prompt, you can use 
your operating system's file copying command to copy font 
files from the library diskette to your work diskette. In 
most cases you will place the work diskette in the A drive 
and the library diskette in the B drive. Then copy the font 
file you want from the library diskette, renaming it to 
FONTB.BIN or FONTC.BIN. 

When you copy the font files, remember to include the 
filetype for the file on the library diskette. Table A-2 does 
not list filetypes because they can vary. 

For detailed information on file copying, refer to your 
operating system manual. 

Replacing default fonts with fonts from the library does 
not change the Style Submenu for the TEXT design ele
ment. The submenu still lists the stroke font styles as Sim
plex, Complex, and Italic. 

The submenu selection Simplex always produces text in the 
font Simplex Roman. Do not try to change the font file 
called DRA W.BIN. 

The submenu selection Complex always uses the font 
file named FONTB.BIN. Although the default font for 
FONTB.BIN is Complex Roman, you can copy any font to 
the work diskette and rename it FONTB.BIN. 

The submenu selection Italic always uses the font file 
named FONTC.BIN. Although the default font for 
FONTC.BIN is Triplex Italic, you can copy any font to the 
work diskette and rename it FONTC.BIN. 
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FONTS AND 
PICTURE 
FILES 
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When you recall a picture file, DR Draw remembers the 
Style Submenu selection you PICKed for each text string 
and uses the font currently in the corresponding font file on 
the program diskette. 

For example, suppose you enter three text strings: 

• "DR Draw," using the submenu selection Simplex 

• "Graphic Application," using the submenu selection 
Complex 

• "User's Guide," using the submenu selection Italic 

If FONTB.BIN and FONTC.BIN contain the default fonts, 
"DR Draw" appears in Simplex Roman, "Graphic Ap
plication" appears in Complex Roman, and "User's 
Guide" appears in Triplex Italic. . 

After you save the picture file, you EXIT from DR Draw. 
Using operating system commands, you copy font files to 
the work diskette, renaming them as follows: 

• GOTIT A to FONTB.BIN 
• SIMSCR to FONTC.BIN 

When you recall the picture file, "DR Draw" still appears 
in Simplex Roman, but "Graphic Application" now 
appears in Gothic Italic and "User's Guide" in Simplex 
Script. 
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ERASING FONT FILES Do not under any circumstances erase any of the font files 
on your library diskette. 

RESTORING FONTS 
TO THE DEFAULTS 

FONT CHARACTER 
SETS 

If you erase FONTB.BIN or FONTC.BIN from the work 
diskette and then PICK either the Complex or Italic sub
menu selection, DR Draw automatically uses Simplex Ro
man. 

If you erase DRA W.BIN, you cannot start DR Draw. You 
see the message: 

No font filest press RETURN 

Press the RETURN key to return to the operating system 
prompt. 

If you change the font files in FONTB.BIN and 
FONTC.BIN, the changes are retained on your work 
diskette. If you want to restore the defaults, you can return 
to the operating system and copy the font files for Complex 
Roman and Triplex Italic from the font library diskette to 
FONTB.BIN and FONTC.BIN, respectively. 

Each of the following figures shows a full character set for 
one of the available fonts. These examples are scaled equal
ly so you can compare the size of the characters in the 
fonts. 

Six fonts have numerals and basic punctuation marks. In 
these fonts, the keyboard pound sign (#) translates to a 
degree symbol, and the left and right angle brackets ( < 
and> ) translate to opening and closing single quotes. 

The remaining six fonts have no numerals or punctuation. 

Note also that the Greek alphabet has no letters corres
ponding to the J and V keys. 

!lID DIGITAL RE.SEARCH@ --------------------------

A-7 



Font Character Sets DR Draw User's Guide 

Ao BbCcOd EeFfGg H h Ii 

J j KkLl M m N nOoPpOq Rr 

SsTtUuVvWwXxYyZz 

1234567890o $&*() 
- == + .. /? ' , I II , . , . . 

Figure A-2 Simplex Roman Character Set 

Aa BbCcDd EeFfGg H h Ii 

JjKkLI MmNnOoPpQq Rr 

SsTtUuVvWwXxYyZz 

1234567890o $&*() 
= = + . . /? ' , , " , . , . . 

Figure A-3. Duplex Roman Character Set 
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AaBbCcDdEeFfGgHhli 

JjKkLIMmNnOoPpQqRr 

SsTtUuVvWwXxYyZz 

1234567890o $&*() 
- == + . . /~ ( ~ , " , . , . . 

Figure A-4. Complex Roman Character Set 

AaB bCcDdE eFfG g Hhli 
JjKkLIMrnNnOoPpQqRr 
SsT t u u V V W w Xx Y yZ z 

1234567890° $&*() 
_==+99 I? ~ ~ y yy 

~ 9 ~ 9 a 

Figure A-S. Indexical Roman Character Set 
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AaBbCcDdEeFfGgHhli 

JJ-KkL lM rnN nO oPp Q q Rr 

SsTtUuVvWwXxYyZz 

1234567890 0 $&*() 
- = + .. /? ' , , , , , . , . . 

Figure A-6. Triplex Italic Character Set 

AaB bCcDdE eFfGgHhli 
J jKkL lMrnN nO oPp Q qRr 

SsTtUuVvWwXxYyZz 
Figure A-7. Indexical Italic Character Set 
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A~m~C~d2~h~XhJ& 

JfXUjX(Umnrv~rPp!2Cf~ 

b~t7b Vu-W ~X(D Ylft? 
Figure A-8. Simplex Script Character Set 

A e»fJ3 & r3 oJ) eLS 0g J<& ~lvJi 

:J jXk;fULrruK n(O ~fP ~CffR~ 

:J ~gtUu;7}~W WX'J)Y ~'f 

1234567890 o$&*() 
- == + .. /Q ' , / / / , . , . . 

Figure A-9. Complex Script Character Set 

Font Character Sets 
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Acx Bf3 H1]6c5 Ec:¢cp I )lXXI0 

KKAAM~NvOonTI8vpp 

LCJTTTv Ow-~'fr1J;Z( 
Figure A-tO. Simplex Greek Character Set 

AcxB (3H 7] ~oE G CPcp f)l Xx IL 
KKA\MMNvOOIT1T819Pp 

~(JTTYV OCJE~'l'1fZ( 
Figure A-l1. Complex Greek Character Set 
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AaBf3H 1} LlO E E<I>cp fyXXIL 
K~AAMMNvOorr~®vpp 

2:aTT'Y'v OwZ~w1/lZ~ 
Figure A-12. Indexical Greek Character Set 

8aflbarOb8r8f8gD~Xi 

11! B kG I rom On 0 0 Qp Q q 8r 

§5C)tauVUOJwxx~yaJ 
Figure A-13. Gothic Italic Character Set 

End of Appendix A 
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AppendixB 

Additional DR Draw Messages 

INTRODUCTION 

STARTING DR Draw 

This appendix describes error messages that you might see 
while starting or using DR Draw. 

When starting DR Draw, you might see one of the follow
mg messages. 

No DRMSGBO.TXT, press RETURN 

If your system has an 80-column display monitor, you can
not start DR Draw without a file called DRMSG80.TXT 
on your work diskette. 

If you see this message, the file DRMSG80.TXT is not on 
your work diskette. Use your operating system's file
copying command to copy the file from the distribution 
diskette you received with your DR Draw package to the 
work diskette. 

No DRMSG40.TXT, press RETURN 

If your system has a 40-column display monitor, you can
not start DR Draw without a file called DRMSG40.TXT 
on your work diskette. 

If you see this message, the file DRMSG40.TXT is not on 
your work diskette. Use your operating system's file
copying command to copy the file from the distribution 
diskette you received with your DR Draw package to the 
work diskette. 
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DRAW, BIN not SIMPROM, nnn , press RETURN 

A font file other than SIMPROM.nnn has been copied and 
renamed to the file DRAW.BIN on the DR Draw work 
diskette. The font named DRA W.BIN must be Simplex 
Roman. The nnn in the above example represents a 
filetype. 

Press the RETURN key, and copy the file SIMPROM.nnn 
from the font library diskette. As you copy the file, rename 
it to DRA W.BIN. 

No ~raphics input, press RETURN 

You see this message if one of the following conditions 
exists. 

1. The GSX program has not been installed. GSX must 
be installed before you can start DR Draw. 

Some systems install GSX automatically when you 
start DR Draw. In other systems you must install GSX 
before you can start DR Draw. Refer to the Supple
ment if you are not sure which type of system you 
have. 

2. In the ASSIGN.SYS file on your work diskette, the 
device driver for your display monitor is either missing 
or incorrectly specified. 

The file specification of the monitor driver in the 
ASSIGN.SYS file is preceded by a logical device num
ber from 01 to 10. 

Ensure that the ASSIGN.SYS file on the work diskette 
meets the following requirements: 

a. A logical device number from 01 to 10 precedes 
the filename of the monitor device driver. 

b. The filename preceded by the logical device num
ber from 01 to 10 corresponds to a monitor device 
driver file on the work diskette. 
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USING DR Draw 

Using DR Draw 

While using DR Draw, you might see one of the following 
messages. 

Cannot add More eleMentSt press DONE 

DR Draw has a limit of two hundred design elements per 
picture file. You see this message if you try to add more 
than two hundred elements. 

Not enou~h space on disKt press DONE 

When you are in a picture file and try to use the CREATE, 
RECALL, or SAVE function, this message appears if insuf
ficient space exists on the diskette where the file will be 
stored. The storage space required varies, depending on the 
function you PICK. 

• CREATE: The diskette must have at least 12 Kilobytes 
of available space, in addition to the size of the file. The 
following two examples illustrate how this restriction 
applies to the CREATE function. 

1. If the diskette has 10 Kilobytes of space when you 
PICK the CREATE function, DR Draw displays 
the message and does not permit you to start the 
new file. You can either delete unwanted files from 
the diskette or use a diskette with sufficient space. 

2. If the diskette has 15 Kilobytes of available space, 
you can start the new file and add design elements 
that consume 3 Kilobytes of space before DR Draw 
displays the message and does not allow you to add 
more design elements. 

Save the file, then delete unwanted files from the 
diskette or copy the file to a diskette with sufficient 
space. 
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• RECALL: When you recall a file, DR Draw produces 
an active picture file by making a copy of the file on 
your diskette. Therefore, the minimum available space 
on the diskette must be 12 Kilobytes plus the size of file 
you are recalling. However, if you intend to add design 
elements to the file, the diskette must have space for the 
new design elements, in addition to the size of the file 
and the 12 Kilobyte minimum. 

If you cannot recall the file or if the diskette has insuf
ficient space for additional design elements, return to 
the operating system. You can delete unwanted files 
from the diskette or copy the file to a diskette with 
sufficient space. 

• SAVE: When you SAVE a file to another drive, the 
diskette on that drive must have available space equal 
to 12 Kilobytes plus the size of the file you are saving. 

To see how much space remains on the diskette and to 
check the size of a picture file, use the appropriate operat
ing system commands. For more information on the com
mands, refer to your operating system manual. 

Bad drive identifiert press DONE 

DR Draw displays this error message when you use a drive 
identifier for a drive that does not exist on your system. 
This situation can arise when you PICK the CREATE, 
RECALL, SAVE, DIRECTORY, and OUTPUT functions. 

For example, if your system has only two drives, A and B, 
and you type 

J:CHART 

in response to the "Picture filename?" prompt, DR Draw 
displays the message. 

End of Appendix B 
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Index 

A 

Active picture file, 4-15 
ADD, 5-3 
Add Submenu, 5-3,6-1 
ARC, 2-46, 6-3 
Arc Submenu, 6-4 
arrow keys, 2-8, 4-8 
attributes, retained, 5-25 

B 

BACKSPACE key, 2-4,4-8, 6-15 
BAR, 2-42, 3-20, 6-6 

c 
CHANGE, 5-4 
change proportions, 

SCALE, 5-31 
Change Submenu, 5-1, 5-4 
CIRCLE, 2-36, 6-7 
Circle Submenu, 6-7 
COLOR, 2-44, 5-5 
Color Submenu, 5-5 
COPY, 2-12, 3-4, 5-6 
correcting typing errors, 6-15 
CREATE, 2-4, 2-35, 5-8 
cross hair, 2-7, 4-7 
current element, 4-9, 5-25 
current style, 4-12 

cursor, 4-7 

D 

change speed, 2-16,4-9 
graphics (cross hair), 

2-7,4-7 
menu, 4-7 
reverse video, 4-7 
text, 4-9, 6-14 

default font, 6-17 
DELETE, 2-11, 3-19, 5-10 
design elements, 6-1 

order, 5-10, 5-43 
DIRECTORY, 2-26, 5-12 
disk drive identifier, 4-16 
DONE, 1-4, 2-6 
DONE/RETURN key, 6-15 
drawing over lines, 6-1 ° 
drawing surface, 4-5 
DRMSG40.TXT, B-1 
DDMSG80.TXT, B-1 

E 

EDIT, 5-13 
Edit Menu, 4-3, 5-13 
error messages, 4-4, 5-2, B-1 

bad drive, B-4 
CREATE, 5-8 
DIRECTORY, 5-12 
EDIT, 5-13 
EXIT, 5-14 
general, B-3 
OUTPUT, 5-21 
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RECALL, 5-24 
SAVE, 5-29 
SCALE, 5-31, 5-33 
starting, B-1 
UNDELETE, 5-43 

EXIT, 2-34, 2-48, 5-14 
extent, 2-11, 4-9 

bouncing, 3-6 
shared, 4-10, 5-39 

F 

filenames, 2-4, 4-14 
filetype, 4-14 
illegal characters, 4-14 
period, 4-14 
spaces in, 4-14 

filetype, 4-14 
FILLED design elements, 

4-12,5-42 
font library, 6-17, A-1 
fonts 

and picture files, A-6 
changing, A-5 
character sets, A-7 
default, 6-17, A-1 
library files, A-3 
machine, 6-17 
restoring, A-7 
stroke, 6-17 

functions, 5-1 

G 

graphics cursor, 2-7, 4-8 
keyboard, 4-8 
mouse, 4-8 
range of motion, 4-8 
speed and distance, 4-9 

GRID, 4-6, 5-15 
GRID OFF, 5-15 
GRID ON, 5-17 
Grid Submenu, 5-15, 5-17 

H 

hollow fill, 4-13 

I 

illegal characters, 4-14 
Initial Style, 4-11 

L 

LANDSCAPE layout, 5 -18 
layout, 5 -18 
LAYOUT, 2-27, 5-18 

default, 2-29 
LINES, 2-6, 2-22, 3-9, 6-9 

M 

machine font, 2-19 
machine fonts, 6-17 
Main Menu, 1-4,2-3,4-2 
MARKERS, 6-11 

groups of, 6-11 
printing, 6-11 
SCALE, 5-34 
size, 6-11 

menu cursor, 4-7 
wrapping, 4-8 

menus, 1-4,4-1 
mouse, 1-4,2-8,4-8 
MOVE, 2-14, 5-20 
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move elements, 
SCALE, 5-31 

N 

non-text elements, 
SCALE, 5-33 

NON-UNIFORM, 5-33 

o 
OPEN design element, 4-12, 5-42 
OUTPUT, 2-32, 5-21 
Output Submenu, 5-21 
Overlapping Elements, 5 -1 0 

p 

PAN, 3-2, 5-47, 6-13 
PICK, 1-3,2-3,2-4,2-6 
picture file diskette, 4-16 
plotting, 5-21 
POLYGON, 2-38,6-12 
PORTRAIT layout, 5-18 
print picture file, 2-32, 5-21 
prompts, 4-4, 5-2, 6-2 
PUT TO BACK, 3-39,5-47 

R 

RECALL, 2-26, 3-1, 3-17, 5-24 
REDRAW, 2-11, 5-28 
reference points, 5-6 
rename picture file, 2-31 
retained attributes, 5-25 
reverse video, 4-7 
rubberband line, 6-9, 6-12 

s 
SAVE, 2-25, 2-47, 3-17, 

3-42,5-29 
SCALE, 3-21, 5-31 
SCREEN layout, 5-18 
SELECT, 3-19, 5-36 
shared extents, 5-39 
SIZE 0.5X, 2-15, 5-16 
SIZE 2X, 5-15 
SNAP, 2-8, 4-6, 5-15 
SNAP OFF, 3-14, 5-16 
SNAP ON, 5-17 
SPACE BAR, 1-4, 2-3 
string, 6-14 
starting, 2-1 
STYLE, 4-11, 5-41 

attributes, 4-11, 5 -41 
BAR, 3-38 
CIRCLE, 2-36 
current, 4-12 
default POLYGON, 2-38 
FILLED, 4-12 
hollow fill, 4-13 
initial, 4-11 
LINES, 3-13 
OPEN,4-12 
POLYGON, 2-38 
TEXT, 2-19, 3-10 

Style Submenu, 5-41 
submenus, 4-4 

I!ID DIGITAL RESEARCH® -----------------------

Index-3 



T 

TAB key, 2-4, 4-8 
TEXT, 2-16,3-8,6-14,6-17 

correcting typing errors, 
6-15 

default fonts, 6-17 
SCALE, 5-31 
string length, 6-15 
ZOOM FULL, 6-18 
ZOOM IN, 6-18 
ZOOM OUT, 6-18 

text cursor, 4-9,6-14 

u 

UNDELETE, 2-11,5-43 
UNIFORM, 5-33 

v 

VIEW, 5-44 
View Submenu, 5-44 

w 
window, 4-6 
window frame, 4-6 

z 
ZOOM FULL, 2-30,3-16,5-16, 

5-45,6-18 
ZOOM IN, 3-29, 5-44,6-13,6-18 
ZOOM OUT, 3-21, 5-16, 

5-47,6-18 
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Dear OEM, 

l!!:!J 
DIGITAL 

RESEARCH® 

Instructions for Customizing DR Draw'· 

When you prepare DR Draw'" for distribution, you will do the 
following: 

• preconfigure a set of device drivers on the DR Draw program 
diskette 

• modify the text file for the GINSTALL program to reflect the 
device drivers you distribute 

• edit the README.DOC file on the DR Draw program diskette 

Because of these changes, you need to prepare a user's guide 
supplement to tell the user how to install DR Draw. To assist you 
in preparing a supplement, enclosed is a copy of the DR Draw Graphic 
A lication User's Guide Su lement for CP/M-a6 e and Concurrent 
CP M'" on the IBM~ Personal Com uter. You need to modify its 
contents to reflect your target computer and diskette configuration 
for DR Draw. The attached technical note identifies the sections 
and subsections of the supplement that might change. 

If you have questions about the technical note or about DR Draw in 
general, please contact your DRI Account Manager or the Technical 
Support Specialist in the DRI regional office nearest you. If they 
are unable to answer your questions, they will contact our Pacific 
Grove office for additional support. 

Thank you for your purchase of DR Draw. We look forward to working 
with you on future DRI software products. 

Sincerely, 
Digital Research Inc. 

5010-1004 
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